summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-07-29 14:01:37 +0200
committerJakob Gahde2016-07-29 14:01:37 +0200
commitca6a44944bc08af76f22cfa2575245226494633b (patch)
treeb9f71c67aae2db533ad90bb447737b94f6c39a42
parentd6180939a3c70c11d2e86070f7779e634af12a6d (diff)
downloadaur-ca6a44944bc08af76f22cfa2575245226494633b.tar.gz
ocaml-ppx_custom_printf 113.33.03-1: New version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--exedir.patch10
3 files changed, 27 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c80017cee4d6..af745c758686 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Sat Feb 6 02:31:46 UTC 2016
+# Fri Jul 29 12:01:15 UTC 2016
pkgbase = ocaml-ppx_custom_printf
pkgdesc = Printf-style format-strings for user-defined string conversion
- pkgver = 113.24.00
+ pkgver = 113.33.03
pkgrel = 1
url = https://github.com/janestreet/ppx_custom_printf
arch = i686
arch = x86_64
license = Apache
makedepends = ocaml-findlib
+ makedepends = ocaml-js-build-tools
makedepends = opam
depends = ocaml
depends = ocaml-ppx_core
@@ -16,10 +17,13 @@ pkgbase = ocaml-ppx_custom_printf
depends = ocaml-ppx_sexp_conv
depends = ocaml-ppx_tools
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/113.24/files/ppx_custom_printf-113.24.00.tar.gz
+ options = !emptydirs
+ source = https://ocaml.janestreet.com/ocaml-core/113.33/files/ppx_custom_printf-113.33.03.tar.gz
source = libdir.patch
- md5sums = a4a7cc1d9c4d20bb521a11e3654866dc
+ source = exedir.patch
+ md5sums = 303cd723860c591491e813a43e846699
md5sums = 7f0a951f1ac87385272ea7a6dd58762a
+ md5sums = 68890ac5a31e5062096ee66bc4ff6c90
pkgname = ocaml-ppx_custom_printf
diff --git a/PKGBUILD b/PKGBUILD
index 98759df91e5f..d4d91fd4cc55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_custom_printf
-pkgver=113.24.00
+pkgver=113.33.03
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="Printf-style format-strings for user-defined string conversion"
url="https://github.com/janestreet/ppx_custom_printf"
depends=('ocaml' 'ocaml-ppx_core' 'ocaml-ppx_driver' 'ocaml-ppx_sexp_conv' 'ocaml-ppx_tools')
-makedepends=('ocaml-findlib' 'opam')
+makedepends=('ocaml-findlib' 'ocaml-js-build-tools' 'opam')
source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz"
- "libdir.patch")
-options=('!strip')
-md5sums=('a4a7cc1d9c4d20bb521a11e3654866dc'
- '7f0a951f1ac87385272ea7a6dd58762a')
+ "libdir.patch"
+ "exedir.patch")
+options=('!strip' '!emptydirs')
+md5sums=('303cd723860c591491e813a43e846699'
+ '7f0a951f1ac87385272ea7a6dd58762a'
+ '68890ac5a31e5062096ee66bc4ff6c90')
prepare() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
patch -Np1 < "${srcdir}/libdir.patch"
+ patch -Np1 < "${srcdir}/exedir.patch"
}
build() {
diff --git a/exedir.patch b/exedir.patch
new file mode 100644
index 000000000000..f12c7ed3f631
--- /dev/null
+++ b/exedir.patch
@@ -0,0 +1,10 @@
+diff -aur package.pristine/install.ml package.new/install.ml
+--- package.pristine/install.ml 2016-07-29 13:58:45.960287314 +0200
++++ package.new/install.ml 2016-07-29 13:58:55.756885106 +0200
+@@ -7,5 +7,5 @@
+ [ oasis_lib "ppx_custom_printf"
+ ; oasis_lib "ppx_format_lifter"
+ ; file "META" ~section:"lib"
+- ; oasis_exe "ppx" ~dest:"../lib/ppx_custom_printf/ppx"
++ ; oasis_exe "ppx" ~dest:"../lib/ocaml/ppx_custom_printf/ppx"
+ ]