summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-06-02 00:16:02 +0200
committerDaniel Peukert2020-06-02 00:16:02 +0200
commitd3bade5c5282d6ac7213bfb1cb2f304691fdc7e0 (patch)
tree08a0b7cb609da8c505b5d1bcde7bdba110577fc9
parentb15ab3a11657be1cd1601e1681bf10f5615b802a (diff)
downloadaur-d3bade5c5282d6ac7213bfb1cb2f304691fdc7e0.tar.gz
Updated janestreet packages
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c8933fd6870..77ddeb6abd2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ppx_custom_printf
pkgdesc = Printf-style format-strings for user-defined string conversion
- pkgver = 0.13.0
- pkgrel = 2
+ pkgver = 0.14.0
+ pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_custom_printf
arch = x86_64
@@ -11,13 +11,13 @@ pkgbase = ocaml-ppx_custom_printf
arch = armv7h
arch = aarch64
license = MIT
- makedepends = dune>=1.5.1
+ makedepends = dune>=2.0.0
depends = ocaml>=4.04.2
- depends = ocaml-base>=0.13.0
- depends = ocaml-ppx_sexp_conv>=0.13.0
- depends = ocaml-ppxlib>=0.9.0
+ depends = ocaml-base>=0.14.0
+ depends = ocaml-ppx_sexp_conv>=0.14.0
+ depends = ocaml-ppxlib>=0.11.0
options = !strip
- source = ocaml-ppx_custom_printf-1:0.13.0-2.tar.gz::https://github.com/janestreet/ppx_custom_printf/archive/v0.13.0.tar.gz
- sha256sums = cc9a7525c8fd79099afb1d4c7b8e7ad91df895246fbdf48188cf6771e734c787
+ source = ocaml-ppx_custom_printf-1:0.14.0-1.tar.gz::https://github.com/janestreet/ppx_custom_printf/archive/v0.14.0.tar.gz
+ sha256sums = c527d5a578a0d6b21a38480b4360b402a27cfcc3361a4092bee16800bf8102d7
pkgname = ocaml-ppx_custom_printf
diff --git a/PKGBUILD b/PKGBUILD
index a742555c32d8..337fe07e7d17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,29 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppx_custom_printf'
pkgname="ocaml-$_projectname"
-pkgver='0.13.0'
-pkgrel='2'
+pkgver='0.14.0'
+pkgrel='1'
epoch='1'
pkgdesc='Printf-style format-strings for user-defined string conversion'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
-depends=('ocaml>=4.04.2' 'ocaml-base>=0.13.0' 'ocaml-ppx_sexp_conv>=0.13.0' 'ocaml-ppxlib>=0.9.0')
-makedepends=('dune>=1.5.1')
+depends=('ocaml>=4.04.2' 'ocaml-base>=0.14.0' 'ocaml-ppx_sexp_conv>=0.14.0' 'ocaml-ppxlib>=0.11.0')
+makedepends=('dune>=2.0.0')
options=('!strip')
source=("$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('cc9a7525c8fd79099afb1d4c7b8e7ad91df895246fbdf48188cf6771e734c787')
+sha256sums=('c527d5a578a0d6b21a38480b4360b402a27cfcc3361a4092bee16800bf8102d7')
_sourcedirectory="$_projectname-$pkgver"
build() {
cd "$srcdir/$_sourcedirectory/"
- dune build -p "$_projectname" --verbose
+ dune build --release --verbose
}
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
install -dm755 "$pkgdir/usr/share/doc/$pkgname"
mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"