summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:10:21 +0100
committerDaniel Peukert2024-01-28 00:10:21 +0100
commit1e311f90783d7e411cb6a4a3b661a583c4d53c76 (patch)
treefef56c9985aa3e3d0ab7b2654369bd1f752f0d16
parent638ac0186f76c014d1bf63d370693860f63e6904 (diff)
downloadaur-1e311f90783d7e411cb6a4a3b661a583c4d53c76.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD9
3 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7969fc2f1d45..8cd8f423b123 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,8 +16,8 @@ pkgbase = ocaml-ppx_deriving
depends = ocaml-ppxlib>=0.20.0
depends = ocaml-result
options = !strip
- source = ocaml-ppx_deriving-1:5.2.1-6.tar.gz::https://github.com/ocaml-ppx/ppx_deriving/archive/v5.2.1.tar.gz
- source = ocaml-ppx_deriving-1:5.2.1-6-fix-ocaml-compat.diff::https://github.com/ocaml-ppx/ppx_deriving/commit/da4d0a0c55184b55c39fccb1d2379984770ddc04.diff
+ source = ocaml-ppx_deriving-5.2.1.tar.gz::https://github.com/ocaml-ppx/ppx_deriving/archive/v5.2.1.tar.gz
+ source = ocaml-ppx_deriving-5.2.1-fix-ocaml-compat.diff::https://github.com/ocaml-ppx/ppx_deriving/commit/da4d0a0c55184b55c39fccb1d2379984770ddc04.diff
sha512sums = 01d2eb920f3375960a9228138ccb5f2af49bfba1111894795c24b3c37d5a021d6bc95e9de1d867c35d03645334300ccc89f1fca0cb75007ec62e5620f328e078
sha512sums = 8975578340dc79ffc0004d137920f9b6f030a013209c3fbac12405107dd5c5a9de6448b16e6e78c569b16cc54ceb35870ab8db917ea16af4f4f0859359d0de13
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index c897779dad11..f69b53f37f75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,6 @@ pkgver='5.2.1'
pkgrel='6'
epoch='1'
pkgdesc='Type-driven code generation for OCaml'
-# If you're running on aarch64, you have to add it to the arch array of the cppo, ocaml-biniou, ocaml-easy-format and ocaml-yojson AUR dependencies
arch=('x86_64' 'aarch64')
url="https://github.com/ocaml-ppx/$_projectname"
license=('MIT')
@@ -15,8 +14,8 @@ makedepends=('cppo' 'dune>=1.6.3')
checkdepends=('ocaml-ounit')
options=('!strip')
source=(
- "$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz"
- "$pkgname-$epoch:$pkgver-$pkgrel-fix-ocaml-compat.diff::$url/commit/da4d0a0c55184b55c39fccb1d2379984770ddc04.diff"
+ "$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ "$pkgname-$pkgver-fix-ocaml-compat.diff::$url/commit/da4d0a0c55184b55c39fccb1d2379984770ddc04.diff"
)
sha512sums=('01d2eb920f3375960a9228138ccb5f2af49bfba1111894795c24b3c37d5a021d6bc95e9de1d867c35d03645334300ccc89f1fca0cb75007ec62e5620f328e078'
'8975578340dc79ffc0004d137920f9b6f030a013209c3fbac12405107dd5c5a9de6448b16e6e78c569b16cc54ceb35870ab8db917ea16af4f4f0859359d0de13')
@@ -25,7 +24,7 @@ _sourcedirectory="$_projectname-$pkgver"
prepare() {
cd "$srcdir/$_sourcedirectory/"
- patch --forward -p1 < "../$pkgname-$epoch:$pkgver-$pkgrel-fix-ocaml-compat.diff"
+ patch --forward -p1 < "../$pkgname-$pkgver-fix-ocaml-compat.diff"
}
build() {
@@ -43,5 +42,5 @@ package() {
DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/MIT"
}