summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMort Yao2018-05-18 23:47:30 +0200
committerMort Yao2018-05-18 23:47:30 +0200
commit535890e8e9f05a3dc48f2856829e29498e96c2c5 (patch)
tree17832f3cc27e1fce89d8e91f55cbe9ad3f12b8d5
downloadaur-535890e8e9f05a3dc48f2856829e29498e96c2c5.tar.gz
ocaml-ppx_deriving-git 20180318-1
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD36
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16098a063332
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri May 18 21:47:11 UTC 2018
+pkgbase = ocaml-ppx_deriving-git
+ pkgdesc = Type-driven code generation for OCaml >=4.02
+ pkgver = 20180318
+ pkgrel = 1
+ url = https://github.com/ocaml-ppx/ppx_deriving
+ arch = x86_64
+ license = MIT
+ makedepends = ocamlbuild
+ makedepends = ocaml-findlib
+ makedepends = cppo
+ depends = ocaml
+ depends = ocaml-migrate-parsetree
+ depends = ocaml-ppx_derivers
+ depends = ocaml-ppx_tools>=4.02.3
+ depends = ocaml-result
+ provides = ocaml-ppx_deriving
+ source = ocaml-ppx_deriving-git::git://github.com/ocaml-ppx/ppx_deriving.git
+ md5sums = SKIP
+
+pkgname = ocaml-ppx_deriving-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..11046d3c70fe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+/pkg
+/src
+*.sig
+*.bz2
+*.gz
+*.tar
+*.xz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cece4aeceae0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Mort Yao <soi@mort.ninja>
+
+pkgname=ocaml-ppx_deriving-git
+pkgver=20180318
+pkgrel=1
+pkgdesc="Type-driven code generation for OCaml >=4.02"
+arch=('x86_64')
+url='https://github.com/ocaml-ppx/ppx_deriving'
+license=('MIT')
+provides=('ocaml-ppx_deriving')
+depends=('ocaml' 'ocaml-migrate-parsetree' 'ocaml-ppx_derivers' 'ocaml-ppx_tools>=4.02.3' 'ocaml-result')
+makedepends=('ocamlbuild' 'ocaml-findlib' 'cppo')
+source=("${pkgname}::git://github.com/ocaml-ppx/ppx_deriving.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git log -1 --pretty=format:%cd --date=short | sed 's/-//g'
+}
+
+build() {
+ cd "$pkgname"
+
+ make
+}
+
+package() {
+ cd "$pkgname"
+
+ export OCAMLPATH="$(ocamlc -where):${pkgdir}$(ocamlc -where)"
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}"
+
+ make install
+ install -Dm644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}