summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:11:10 +0100
committerDaniel Peukert2024-01-28 00:11:10 +0100
commitce0f79d4a6c2b661733a35882281d1747a9b67a1 (patch)
tree99f5b993588d07bb2f500d00813d8fb34304dbfd
parented91d4611e8faba807ded2f9abcf5bb8cf5e3513 (diff)
downloadaur-ocaml-ppx_hash.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD5
3 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c12b217332e..31f34e713bbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,7 @@ pkgbase = ocaml-ppx_hash
depends = ocaml-ppx_sexp_conv>=0.16.0
depends = ocaml-ppxlib>=0.28.0
options = !strip
- source = ocaml-ppx_hash-0.16.0-1.tar.gz::https://github.com/janestreet/ppx_hash/archive/v0.16.0.tar.gz
+ source = ocaml-ppx_hash-0.16.0.tar.gz::https://github.com/janestreet/ppx_hash/archive/v0.16.0.tar.gz
sha512sums = b06f67fa0550a40a96fd02e1b65240470a014fcf6f6d4f0f21f77d2d7f2eaba3b86faef462d329b416f9e6234f287ac3a3c72875cbac53b0532d8ab82c0199e7
pkgname = ocaml-ppx_hash
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index b474dabb447b..020d6736125a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,13 @@ pkgname="ocaml-$_projectname"
pkgver='0.16.0'
pkgrel='1'
pkgdesc='A ppx rewriter that generates hash functions from type expressions and definitions'
-# If you're running on aarch64, you have to add it to the arch array of the ocaml-biniou, ocaml-easy-format and ocaml-yojson AUR dependencies
arch=('x86_64' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
depends=('ocaml>=4.14.0' 'ocaml-base>=0.16.0' 'ocaml-ppx_compare>=0.16.0' 'ocaml-ppx_sexp_conv>=0.16.0' 'ocaml-ppxlib>=0.28.0')
makedepends=('dune>=2.0.0')
options=('!strip')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha512sums=('b06f67fa0550a40a96fd02e1b65240470a014fcf6f6d4f0f21f77d2d7f2eaba3b86faef462d329b416f9e6234f287ac3a3c72875cbac53b0532d8ab82c0199e7')
_sourcedirectory="$_projectname-$pkgver"
@@ -27,5 +26,5 @@ package() {
DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/MIT"
}