summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-06-02 00:17:01 +0200
committerDaniel Peukert2020-06-02 00:17:01 +0200
commit99a476bb7cc9047a7c056aae4da28894c5282559 (patch)
treef2faabdf0fba46dba39dec5b25d7f0b48d686afe
parent99b93e1edb48b0a41a0a4151b10564e5e0c9520d (diff)
downloadaur-99a476bb7cc9047a7c056aae4da28894c5282559.tar.gz
Updated janestreet packages
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95b66bd397a6..302fafd56171 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ppx_hash
pkgdesc = A ppx rewriter that generates hash functions from type expressions and definitions
- pkgver = 0.13.0
- pkgrel = 2
+ pkgver = 0.14.0
+ pkgrel = 1
url = https://github.com/janestreet/ppx_hash
arch = x86_64
arch = i686
@@ -10,14 +10,14 @@ pkgbase = ocaml-ppx_hash
arch = armv7h
arch = aarch64
license = MIT
- makedepends = dune>=1.5.1
+ makedepends = dune>=2.0.0
depends = ocaml>=4.04.2
- depends = ocaml-base>=0.13.0
- depends = ocaml-ppx_compare>=0.13.0
- depends = ocaml-ppx_sexp_conv>=0.13.0
- depends = ocaml-ppxlib>=0.9.0
+ depends = ocaml-base>=0.14.0
+ depends = ocaml-ppx_compare>=0.14.0
+ depends = ocaml-ppx_sexp_conv>=0.14.0
+ depends = ocaml-ppxlib>=0.11.0
options = !strip
- source = ocaml-ppx_hash-0.13.0-2.tar.gz::https://github.com/janestreet/ppx_hash/archive/v0.13.0.tar.gz
- sha256sums = fc7d8f9c0ec3ae859f38509419a36754456c15067a1e180d0e80a970726b010c
+ source = ocaml-ppx_hash-0.14.0-1.tar.gz::https://github.com/janestreet/ppx_hash/archive/v0.14.0.tar.gz
+ sha256sums = bfd7d82db037329239db5ea73b7ec08bb40979263d43858c649826408b66db2e
pkgname = ocaml-ppx_hash
diff --git a/PKGBUILD b/PKGBUILD
index 88c0028a818f..24fa18144aa0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,28 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppx_hash'
pkgname="ocaml-$_projectname"
-pkgver='0.13.0'
-pkgrel='2'
+pkgver='0.14.0'
+pkgrel='1'
pkgdesc='A ppx rewriter that generates hash functions from type expressions and definitions'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
-depends=('ocaml>=4.04.2' 'ocaml-base>=0.13.0' 'ocaml-ppx_compare>=0.13.0' 'ocaml-ppx_sexp_conv>=0.13.0' 'ocaml-ppxlib>=0.9.0')
-makedepends=('dune>=1.5.1')
+depends=('ocaml>=4.04.2' 'ocaml-base>=0.14.0' 'ocaml-ppx_compare>=0.14.0' 'ocaml-ppx_sexp_conv>=0.14.0' 'ocaml-ppxlib>=0.11.0')
+makedepends=('dune>=2.0.0')
options=('!strip')
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('fc7d8f9c0ec3ae859f38509419a36754456c15067a1e180d0e80a970726b010c')
+sha256sums=('bfd7d82db037329239db5ea73b7ec08bb40979263d43858c649826408b66db2e')
_sourcedirectory="$_projectname-$pkgver"
build() {
cd "$srcdir/$_sourcedirectory/"
- dune build -p "$_projectname" --verbose
+ dune build --release --verbose
}
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
install -dm755 "$pkgdir/usr/share/doc/$pkgname"
mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"