summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-07-29 13:09:36 +0200
committerJakob Gahde2016-07-29 13:09:36 +0200
commit3682fd6f24ea6cf32acad9929d10fd8c1d0e072b (patch)
treed0ec2cc15a336c0f8f76afc7f32dd3b23c3041dc
parentb04c4d230b6b98ba3fb9056a3500ba24205f237d (diff)
downloadaur-3682fd6f24ea6cf32acad9929d10fd8c1d0e072b.tar.gz
ocaml-ppx_here 113.33.03-1: New version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--exedir.patch10
3 files changed, 27 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e60560a525c..f3950e52ad90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,27 @@
# Generated by mksrcinfo v8
-# Sat Feb 6 02:12:26 UTC 2016
+# Fri Jul 29 11:09:13 UTC 2016
pkgbase = ocaml-ppx_here
pkgdesc = Expands [%here] into its location
- pkgver = 113.24.00
+ pkgver = 113.33.03
pkgrel = 1
url = https://github.com/janestreet/ppx_here
arch = i686
arch = x86_64
license = Apache
makedepends = ocaml-findlib
+ makedepends = ocaml-js-build-tools
makedepends = opam
depends = ocaml
depends = ocaml-ppx_core
depends = ocaml-ppx_driver
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/113.24/files/ppx_here-113.24.00.tar.gz
+ options = !emptydirs
+ source = https://ocaml.janestreet.com/ocaml-core/113.33/files/ppx_here-113.33.03.tar.gz
source = libdir.patch
- md5sums = 41c99e2492ef2a14ffe3d8626a20a5a1
+ source = exedir.patch
+ md5sums = 4bdb1122a2952a31674d403477ed66c2
md5sums = 7f0a951f1ac87385272ea7a6dd58762a
+ md5sums = 49475ccc437692638b7079784aa66c1e
pkgname = ocaml-ppx_here
diff --git a/PKGBUILD b/PKGBUILD
index 5bb01ec55cd1..f947f826b4b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_here
-pkgver=113.24.00
+pkgver=113.33.03
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="Expands [%here] into its location"
url="https://github.com/janestreet/ppx_here"
depends=('ocaml' 'ocaml-ppx_core' 'ocaml-ppx_driver')
-makedepends=('ocaml-findlib' 'opam')
+makedepends=('ocaml-findlib' 'ocaml-js-build-tools' 'opam')
source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz"
- "libdir.patch")
-options=('!strip')
-md5sums=('41c99e2492ef2a14ffe3d8626a20a5a1'
- '7f0a951f1ac87385272ea7a6dd58762a')
+ "libdir.patch"
+ "exedir.patch")
+options=('!strip' '!emptydirs')
+md5sums=('4bdb1122a2952a31674d403477ed66c2'
+ '7f0a951f1ac87385272ea7a6dd58762a'
+ '49475ccc437692638b7079784aa66c1e')
prepare() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
patch -Np1 < "${srcdir}/libdir.patch"
+ patch -Np1 < "${srcdir}/exedir.patch"
}
build() {
diff --git a/exedir.patch b/exedir.patch
new file mode 100644
index 000000000000..7f73bb186a1d
--- /dev/null
+++ b/exedir.patch
@@ -0,0 +1,10 @@
+diff -aur package.pristine/install.ml package.new/install.ml
+--- package.pristine/install.ml 2016-07-29 13:01:35.333440959 +0200
++++ package.new/install.ml 2016-07-29 13:02:41.696342607 +0200
+@@ -7,5 +7,5 @@
+ [ oasis_lib "ppx_here"
+ ; oasis_lib "ppx_here_expander"
+ ; file "META" ~section:"lib"
+- ; oasis_exe "ppx" ~dest:"../lib/ppx_here/ppx"
++ ; oasis_exe "ppx" ~dest:"../lib/ocaml/ppx_here/ppx"
+ ]