summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2022-06-14 20:39:39 +0200
committerDaniel Peukert2022-06-14 20:39:39 +0200
commit7f1698ce326f34eb98d463afcb802176f0fa3b70 (patch)
tree2626b3e125d57d7a003e458ad7cf0e77be25413f
parentdf3ab3c39331100660b08b51c57324830f9163b2 (diff)
downloadaur-7f1698ce326f34eb98d463afcb802176f0fa3b70.tar.gz
Fix dun calls, sha256 -> sha512
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 4 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdf091fb3484..cc69c49a398b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ppx_here
pkgdesc = Expands [%here] into its location
pkgver = 0.15.0
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/janestreet/ppx_here
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = ocaml-ppx_here
depends = ocaml-base>=0.15.0
depends = ocaml-ppxlib>=0.23.0
options = !strip
- source = ocaml-ppx_here-1:0.15.0-1.tar.gz::https://github.com/janestreet/ppx_here/archive/v0.15.0.tar.gz
+ source = ocaml-ppx_here-1:0.15.0-2.tar.gz::https://github.com/janestreet/ppx_here/archive/v0.15.0.tar.gz
sha512sums = 708bd2edf9390f251e1c76e63462692c01372c7d7c7b54e45347e87ee7da999392148b61a187f2106fbc37d626663260d331982a005bd2f98f9bd6bc8f326cf5
pkgname = ocaml-ppx_here
diff --git a/PKGBUILD b/PKGBUILD
index 9f76e86a39af..f40071ceeff8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_projectname='ppx_here'
pkgname="ocaml-$_projectname"
pkgver='0.15.0'
-pkgrel='1'
+pkgrel='2'
epoch='1'
pkgdesc='Expands [%here] into its location'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -30,11 +30,7 @@ build() {
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
-
- install -dm755 "$pkgdir/usr/share/doc/$pkgname"
- mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
- rm -r "$pkgdir/usr/doc/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"