summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-06-02 00:17:13 +0200
committerDaniel Peukert2020-06-02 00:17:13 +0200
commit8c0304bd7868ddba526711f31f87038e4e30f9be (patch)
treed69b813f7a57e6a026d260954029e5fbeb1104f5
parentb6c17bf5be0fded036dbb291a6fe3f090467ab6a (diff)
downloadaur-8c0304bd7868ddba526711f31f87038e4e30f9be.tar.gz
Updated janestreet packages
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46597c0f3c5b..17aa13008736 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ppx_here
pkgdesc = Expands [%here] into its location
- pkgver = 0.13.0
- pkgrel = 2
+ pkgver = 0.14.0
+ pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_here
arch = x86_64
@@ -11,12 +11,12 @@ pkgbase = ocaml-ppx_here
arch = armv7h
arch = aarch64
license = MIT
- makedepends = dune>=1.5.1
+ makedepends = dune>=2.0.0
depends = ocaml>=4.04.2
- depends = ocaml-base>=0.13.0
- depends = ocaml-ppxlib>=0.9.0
+ depends = ocaml-base>=0.14.0
+ depends = ocaml-ppxlib>=0.11.0
options = !strip
- source = ocaml-ppx_here-1:0.13.0-2.tar.gz::https://github.com/janestreet/ppx_here/archive/v0.13.0.tar.gz
- sha256sums = 32522bd79cf7bcc960729dc6ccb20a2273a4ffde16b86ae1a13ea2fcb94225df
+ source = ocaml-ppx_here-1:0.14.0-1.tar.gz::https://github.com/janestreet/ppx_here/archive/v0.14.0.tar.gz
+ sha256sums = 9acc67b2a040181373f1db2da8913d873f01458a01e2d3e72d0c092e7abc6f90
pkgname = ocaml-ppx_here
diff --git a/PKGBUILD b/PKGBUILD
index 5a6b1e75bbf4..6f6daf75d406 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,35 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppx_here'
pkgname="ocaml-$_projectname"
-pkgver='0.13.0'
-pkgrel='2'
+pkgver='0.14.0'
+pkgrel='1'
epoch='1'
pkgdesc='Expands [%here] into its location'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
-depends=('ocaml>=4.04.2' 'ocaml-base>=0.13.0' 'ocaml-ppxlib>=0.9.0')
-makedepends=('dune>=1.5.1')
+depends=('ocaml>=4.04.2' 'ocaml-base>=0.14.0' 'ocaml-ppxlib>=0.11.0')
+makedepends=('dune>=2.0.0')
options=('!strip')
source=("$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('32522bd79cf7bcc960729dc6ccb20a2273a4ffde16b86ae1a13ea2fcb94225df')
+sha256sums=('9acc67b2a040181373f1db2da8913d873f01458a01e2d3e72d0c092e7abc6f90')
_sourcedirectory="$_projectname-$pkgver"
build() {
cd "$srcdir/$_sourcedirectory/"
- dune build -p "$_projectname" --verbose
+ dune build --release --verbose
}
# fails with "Error: No rule found for test/dummy.ml.pp"
# check() {
# cd "$srcdir/$_sourcedirectory/"
-# dune runtest -p "$_projectname" --verbose
+# dune runtest --release --verbose
# }
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
install -dm755 "$pkgdir/usr/share/doc/$pkgname"
mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"