summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-05-15 10:20:43 +0200
committerJakob Gahde2019-05-15 10:20:43 +0200
commitd0142e42a28497ef96af3b42ee7115b00a1ab1d4 (patch)
tree9ef0d0aa72b01cefe6af976ce45012aa35d20a48
parent375387e74e846b8a3ec8df61e330920c65428878 (diff)
downloadaur-d0142e42a28497ef96af3b42ee7115b00a1ab1d4.tar.gz
ocaml-ppx_here 1:0.12.0-1: New version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ef523daa694..2fa68aaf47e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,20 @@
-# Generated by mksrcinfo v8
-# Thu Jun 28 13:59:41 UTC 2018
pkgbase = ocaml-ppx_here
pkgdesc = Expands [%here] into its location
- pkgver = 0.11.0
+ pkgver = 0.12.0
pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_here
arch = i686
arch = x86_64
- license = Apache
+ license = MIT
makedepends = dune
depends = ocaml
depends = ocaml-base
- depends = ocaml-migrate-parsetree
depends = ocaml-ppxlib
options = !strip
options = !emptydirs
- source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/ppx_here-v0.11.0.tar.gz
- md5sums = 479c9cd5f6ef90c2df9f01eab9d6c91d
+ source = https://ocaml.janestreet.com/ocaml-core/v0.12/files/ppx_here-v0.12.0.tar.gz
+ sha512sums = 3df1fac265a599e65b23b7d514757b9a1a3f0003616806eb3ca824c95d3809b7588310672bf9a6e124a858d47294db835a846a51bb319f621f28ec2e6b2f4b00
pkgname = ocaml-ppx_here
diff --git a/PKGBUILD b/PKGBUILD
index d3fe1254fc0b..c839fa10f42a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_here
-pkgver=0.11.0
+pkgver=0.12.0
pkgrel=1
epoch=1
pkgdesc="Expands [%here] into its location"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/ppx_here"
-license=('Apache')
-depends=('ocaml' 'ocaml-base' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+license=('MIT')
+depends=('ocaml' 'ocaml-base' 'ocaml-ppxlib')
makedepends=('dune')
options=('!strip' '!emptydirs')
source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/ppx_here-v${pkgver}.tar.gz")
-md5sums=('479c9cd5f6ef90c2df9f01eab9d6c91d')
+sha512sums=('3df1fac265a599e65b23b7d514757b9a1a3f0003616806eb3ca824c95d3809b7588310672bf9a6e124a858d47294db835a846a51bb319f621f28ec2e6b2f4b00')
build() {
cd "${srcdir}/ppx_here-v${pkgver}"
- jbuilder build
+ dune build
}
package() {
cd "${srcdir}/ppx_here-v${pkgver}"
install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgdir}/LICENSE.md"
}