summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:11:29 +0100
committerDaniel Peukert2024-01-28 00:11:29 +0100
commit2b4b167448b13e3d39461870f98b47ff1a20c183 (patch)
tree9b6bd3b383c0cf9fd3d859e79103e51809d6e1ee
parent28e97a44705b7defae32c5f3cee431cb9e98d885 (diff)
downloadaur-ocaml-ppx_inline_test.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD2
2 files changed, 15 insertions, 15 deletions
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index d403bca5764c..ec4e65fc35c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,5 +37,5 @@ package() {
done
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/MIT"
}