summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-07-29 13:45:05 +0200
committerJakob Gahde2016-07-29 13:45:05 +0200
commit388336a54819fad564b4c00ddde36f2d78932f81 (patch)
tree0e3e46a1270bdbb451be69097e6fc69aca7b664d
parentb9eaa3603ca97b65de5c535dd5a6aae841821024 (diff)
downloadaur-388336a54819fad564b4c00ddde36f2d78932f81.tar.gz
ocaml-ppx_inline_test 113.33.03-1: New version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--exedir.patch10
3 files changed, 27 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20a77327182d..2fb906e1df9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,28 @@
# Generated by mksrcinfo v8
-# Sat Feb 6 02:22:24 UTC 2016
+# Fri Jul 29 11:44:43 UTC 2016
pkgbase = ocaml-ppx_inline_test
pkgdesc = Syntax extension for writing in-line tests in ocaml code
- pkgver = 113.24.00
+ pkgver = 113.33.03
pkgrel = 1
url = https://github.com/janestreet/ppx_inline_test
arch = i686
arch = x86_64
license = Apache
makedepends = ocaml-findlib
+ makedepends = ocaml-js-build-tools
makedepends = opam
depends = ocaml
depends = ocaml-ppx_core
depends = ocaml-ppx_driver
depends = ocaml-ppx_tools
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/113.24/files/ppx_inline_test-113.24.00.tar.gz
+ options = !emptydirs
+ source = https://ocaml.janestreet.com/ocaml-core/113.33/files/ppx_inline_test-113.33.03.tar.gz
source = libdir.patch
- md5sums = 5d80120af94ba974670a0a28b1200160
+ source = exedir.patch
+ md5sums = 6abbbcbe8aefbb9d30721e252cd5c7f4
md5sums = 7f0a951f1ac87385272ea7a6dd58762a
+ md5sums = e4d9f81044407306bb88373ae2e12932
pkgname = ocaml-ppx_inline_test
diff --git a/PKGBUILD b/PKGBUILD
index 2f4f8d18d89e..33746f686ad1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_inline_test
-pkgver=113.24.00
+pkgver=113.33.03
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="Syntax extension for writing in-line tests in ocaml code"
url="https://github.com/janestreet/ppx_inline_test"
depends=('ocaml' 'ocaml-ppx_core' 'ocaml-ppx_driver' 'ocaml-ppx_tools')
-makedepends=('ocaml-findlib' 'opam')
+makedepends=('ocaml-findlib' 'ocaml-js-build-tools' 'opam')
source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz"
- "libdir.patch")
-options=('!strip')
-md5sums=('5d80120af94ba974670a0a28b1200160'
- '7f0a951f1ac87385272ea7a6dd58762a')
+ "libdir.patch"
+ "exedir.patch")
+options=('!strip' '!emptydirs')
+md5sums=('6abbbcbe8aefbb9d30721e252cd5c7f4'
+ '7f0a951f1ac87385272ea7a6dd58762a'
+ 'e4d9f81044407306bb88373ae2e12932')
prepare() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
patch -Np1 < "${srcdir}/libdir.patch"
+ patch -Np1 < "${srcdir}/exedir.patch"
}
build() {
diff --git a/exedir.patch b/exedir.patch
new file mode 100644
index 000000000000..97aa0c58aae4
--- /dev/null
+++ b/exedir.patch
@@ -0,0 +1,10 @@
+diff -aur package.pristine/install.ml package.new/install.ml
+--- package.pristine/install.ml 2016-07-29 13:41:43.227429332 +0200
++++ package.new/install.ml 2016-07-29 13:42:35.617075757 +0200
+@@ -11,5 +11,5 @@
+ ; oasis_lib "ppx_inline_test_libname"
+ ; oasis_obj "ppx_inline_test_runner"
+ ; file "META" ~section:"lib"
+- ; oasis_exe "ppx" ~dest:"../lib/ppx_inline_test/ppx"
++ ; oasis_exe "ppx" ~dest:"../lib/ocaml/ppx_inline_test/ppx"
+ ]