summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-05-15 14:11:34 +0200
committerJakob Gahde2019-05-15 14:11:34 +0200
commit6c84d0c9ad7a9763f603d9b429a66f79c2317191 (patch)
treea6eb87811d2ea2bb33024fec5dfcb69e7dc4313e
parent595d9e42f9f9c57ae1253d290e7c70e145d3615b (diff)
downloadaur-6c84d0c9ad7a9763f603d9b429a66f79c2317191.tar.gz
ocaml-ppx_inline_test 1:0.12.0-1: New version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5200f3ba3709..d478c1f21b31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = ocaml-ppx_inline_test
pkgdesc = Syntax extension for writing in-line tests in ocaml code
- pkgver = 0.11.0
- pkgrel = 2
+ pkgver = 0.12.0
+ pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_inline_test
arch = i686
arch = x86_64
- license = Apache
+ license = MIT
makedepends = dune
depends = ocaml
depends = ocaml-base
- depends = ocaml-migrate-parsetree
depends = ocaml-ppxlib
options = !strip
options = !emptydirs
- source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/ppx_inline_test-v0.11.0.tar.gz
- md5sums = 1f2e014332373638696d8893d87f4682
+ source = https://ocaml.janestreet.com/ocaml-core/v0.12/files/ppx_inline_test-v0.12.0.tar.gz
+ sha512sums = 136555310442e479b676167d44a6dffb6f56517359165fe64778e863fd58021524a2fcd1d1246cd705fab62e3e510c60afcb20a574ac43687c86b7bbd990936d
pkgname = ocaml-ppx_inline_test
diff --git a/PKGBUILD b/PKGBUILD
index 637dbbf2e3f9..6c7b073daede 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_inline_test
-pkgver=0.11.0
-pkgrel=2
+pkgver=0.12.0
+pkgrel=1
epoch=1
pkgdesc="Syntax extension for writing in-line tests in ocaml code"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/ppx_inline_test"
-license=('Apache')
-depends=('ocaml' 'ocaml-base' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+license=('MIT')
+depends=('ocaml' 'ocaml-base' 'ocaml-ppxlib')
makedepends=('dune')
options=('!strip' '!emptydirs')
source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/ppx_inline_test-v${pkgver}.tar.gz")
-md5sums=('1f2e014332373638696d8893d87f4682')
+sha512sums=('136555310442e479b676167d44a6dffb6f56517359165fe64778e863fd58021524a2fcd1d1246cd705fab62e3e510c60afcb20a574ac43687c86b7bbd990936d')
build() {
cd "${srcdir}/ppx_inline_test-v${pkgver}"
- jbuilder build
+ dune build
}
package() {
cd "${srcdir}/ppx_inline_test-v${pkgver}"
install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}