summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:11:35 +0100
committerDaniel Peukert2024-01-28 00:11:35 +0100
commit6fad8666c04e7e977e14b20bad93f49ddece97ef (patch)
tree2c13ca2fb817a3af1848dfb51f949a64a05462e1
parentdeacf024732a77d72d544f4cc8c2bcce11feecaa (diff)
downloadaur-6fad8666c04e7e977e14b20bad93f49ddece97ef.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD5
3 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 759394084103..e919a6a12fa8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -37,7 +37,7 @@ pkgbase = ocaml-ppx_jane
depends = ocaml-ppx_variants_conv>=0.16.0
depends = ocaml-ppxlib>=0.28.0
options = !strip
- source = ocaml-ppx_jane-1:0.16.0-1.tar.gz::https://github.com/janestreet/ppx_jane/archive/v0.16.0.tar.gz
+ source = ocaml-ppx_jane-0.16.0.tar.gz::https://github.com/janestreet/ppx_jane/archive/v0.16.0.tar.gz
sha512sums = 8bb5997eb33a2f8ef7ec88d5a31c03828cc6f7070641463ad5af318b865fe8638b1affa359db07e8880364598b43ad19621882cf4c3311e38cf0638a59271652
pkgname = ocaml-ppx_jane
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index d19b5cdd86bf..ce2b4f3ff1b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,13 @@ pkgver='0.16.0'
pkgrel='1'
epoch='1'
pkgdesc='Standard Jane Street ppx rewriters'
-# If you're running on aarch64, you have to add it to the arch array of the ocaml-biniou, ocaml-easy-format and ocaml-yojson AUR dependencies
arch=('x86_64' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
depends=('ocaml>=4.14.0' 'ocaml-base_quickcheck>=0.16.0' 'ocaml-ppx_assert>=0.16.0' 'ocaml-ppx_base>=0.16.0' 'ocaml-ppx_bench>=0.16.0' 'ocaml-ppx_bin_prot>=0.16.0' 'ocaml-ppx_custom_printf>=0.16.0' 'ocaml-ppx_disable_unused_warnings>=0.16.0' 'ocaml-ppx_expect>=0.16.0' 'ocaml-ppx_fields_conv>=0.16.0' 'ocaml-ppx_fixed_literal>=0.16.0' 'ocaml-ppx_here>=0.16.0' 'ocaml-ppx_ignore_instrumentation>=0.16.0' 'ocaml-ppx_inline_test>=0.16.0' 'ocaml-ppx_let>=0.16.0' 'ocaml-ppx_log>=0.16.0' 'ocaml-ppx_module_timer>=0.16.0' 'ocaml-ppx_optional>=0.16.0' 'ocaml-ppx_pipebang>=0.16.0' 'ocaml-ppx_sexp_message>=0.16.0' 'ocaml-ppx_sexp_value>=0.16.0' 'ocaml-ppx_stable>=0.16.0' 'ocaml-ppx_stable_witness>=0.16.0' 'ocaml-ppx_string>=0.16.0' 'ocaml-ppx_tydi>=0.16.0' 'ocaml-ppx_typerep_conv>=0.16.0' 'ocaml-ppx_variants_conv>=0.16.0' 'ocaml-ppxlib>=0.28.0')
makedepends=('dune>=2.0.0')
options=('!strip')
-source=("$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha512sums=('8bb5997eb33a2f8ef7ec88d5a31c03828cc6f7070641463ad5af318b865fe8638b1affa359db07e8880364598b43ad19621882cf4c3311e38cf0638a59271652')
_sourcedirectory="$_projectname-$pkgver"
@@ -28,5 +27,5 @@ package() {
DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/MIT"
}