summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-03-21 21:30:43 +0100
committerDaniel Peukert2020-03-21 21:30:43 +0100
commitb54b0e267ca5b8054344941838eeed5af8b28422 (patch)
tree8b1b95d5229ea88305e9c0d2dd3181fe1d39441d
parent9038302869fb962f3d3c5aa1d69f80fc15a8fce0 (diff)
downloadaur-b54b0e267ca5b8054344941838eeed5af8b28422.tar.gz
Added ocaml-ppx_jane and the rest of its dependencies
-rw-r--r--.SRCINFO63
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD48
4 files changed, 82 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1430075792c..32ea2f5f2f1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,42 @@
-# Generated by mksrcinfo v8
-# Thu Jun 28 17:43:21 UTC 2018
pkgbase = ocaml-ppx_jane
pkgdesc = Standard Jane Street ppx rewriters
- pkgver = 0.11.0
+ pkgver = 0.13.0
pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_jane
- arch = i686
arch = x86_64
- license = Apache
- makedepends = dune
- depends = ocaml
- depends = ocaml-ppx_assert
- depends = ocaml-ppx_base
- depends = ocaml-ppx_bench
- depends = ocaml-ppx_bin_prot
- depends = ocaml-ppx_custom_printf
- depends = ocaml-ppx_expect
- depends = ocaml-ppx_fail
- depends = ocaml-ppx_fields_conv
- depends = ocaml-ppx_here
- depends = ocaml-ppx_inline_test
- depends = ocaml-ppx_let
- depends = ocaml-ppx_optcomp
- depends = ocaml-ppx_optional
- depends = ocaml-ppx_pipebang
- depends = ocaml-ppx_sexp_message
- depends = ocaml-ppx_sexp_value
- depends = ocaml-ppx_typerep_conv
- depends = ocaml-ppx_variants_conv
- depends = ocaml-migrate-parsetree
- depends = ocaml-ppxlib
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = dune>=1.5.1
+ depends = ocaml>=4.04.2
+ depends = ocaml-base_quickcheck>=0.13.0
+ depends = ocaml-ppx_assert>=0.13.0
+ depends = ocaml-ppx_base>=0.13.0
+ depends = ocaml-ppx_bench>=0.13.0
+ depends = ocaml-ppx_bin_prot>=0.13.0
+ depends = ocaml-ppx_custom_printf>=0.13.0
+ depends = ocaml-ppx_expect>=0.13.0
+ depends = ocaml-ppx_fail>=0.13.0
+ depends = ocaml-ppx_fields_conv>=0.13.0
+ depends = ocaml-ppx_here>=0.13.0
+ depends = ocaml-ppx_inline_test>=0.13.0
+ depends = ocaml-ppx_let>=0.13.0
+ depends = ocaml-ppx_module_timer>=0.13.0
+ depends = ocaml-ppx_optcomp>=0.13.0
+ depends = ocaml-ppx_optional>=0.13.0
+ depends = ocaml-ppx_pipebang>=0.13.0
+ depends = ocaml-ppx_sexp_message>=0.13.0
+ depends = ocaml-ppx_sexp_value>=0.13.0
+ depends = ocaml-ppx_stable>=0.13.0
+ depends = ocaml-ppx_typerep_conv>=0.13.0
+ depends = ocaml-ppx_variants_conv>=0.13.0
+ depends = ocaml-ppxlib>=0.9.0
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/ppx_jane-v0.11.0.tar.gz
- md5sums = 11da0871ae3841fb6710ec6471ce6b92
+ source = ocaml-ppx_jane-0.13.0-1.tar.gz::https://github.com/janestreet/ppx_jane/archive/v0.13.0.tar.gz
+ sha256sums = b1d49e946babf5f26be5a4b1b4f36bbf3ae3ac5118ca56b1f9adff1dda37d9c3
pkgname = ocaml-ppx_jane
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index c2c67110f3ba..55eb28a4b072 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,35 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
-
-pkgname=ocaml-ppx_jane
-pkgver=0.11.0
-pkgrel=1
-epoch=1
-pkgdesc="Standard Jane Street ppx rewriters"
-arch=('i686' 'x86_64')
-url="https://github.com/janestreet/ppx_jane"
-license=('Apache')
-depends=('ocaml' 'ocaml-ppx_assert' 'ocaml-ppx_base' 'ocaml-ppx_bench' 'ocaml-ppx_bin_prot' 'ocaml-ppx_custom_printf' 'ocaml-ppx_expect' 'ocaml-ppx_fail' 'ocaml-ppx_fields_conv' 'ocaml-ppx_here' 'ocaml-ppx_inline_test' 'ocaml-ppx_let' 'ocaml-ppx_optcomp' 'ocaml-ppx_optional' 'ocaml-ppx_pipebang' 'ocaml-ppx_sexp_message' 'ocaml-ppx_sexp_value' 'ocaml-ppx_typerep_conv' 'ocaml-ppx_variants_conv' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
-makedepends=('dune')
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
+_projectname='ppx_jane'
+pkgname="ocaml-$_projectname"
+pkgver='0.13.0'
+pkgrel='1'
+epoch='1'
+pkgdesc='Standard Jane Street ppx rewriters'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/janestreet/$_projectname"
+license=('MIT')
+depends=('ocaml>=4.04.2' 'ocaml-base_quickcheck>=0.13.0' 'ocaml-ppx_assert>=0.13.0' 'ocaml-ppx_base>=0.13.0' 'ocaml-ppx_bench>=0.13.0' 'ocaml-ppx_bin_prot>=0.13.0' 'ocaml-ppx_custom_printf>=0.13.0' 'ocaml-ppx_expect>=0.13.0' 'ocaml-ppx_fail>=0.13.0' 'ocaml-ppx_fields_conv>=0.13.0' 'ocaml-ppx_here>=0.13.0' 'ocaml-ppx_inline_test>=0.13.0' 'ocaml-ppx_let>=0.13.0' 'ocaml-ppx_module_timer>=0.13.0' 'ocaml-ppx_optcomp>=0.13.0' 'ocaml-ppx_optional>=0.13.0' 'ocaml-ppx_pipebang>=0.13.0' 'ocaml-ppx_sexp_message>=0.13.0' 'ocaml-ppx_sexp_value>=0.13.0' 'ocaml-ppx_stable>=0.13.0' 'ocaml-ppx_typerep_conv>=0.13.0' 'ocaml-ppx_variants_conv>=0.13.0' 'ocaml-ppxlib>=0.9.0')
+makedepends=('dune>=1.5.1')
options=('!strip')
-source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/ppx_jane-v${pkgver}.tar.gz")
-md5sums=('11da0871ae3841fb6710ec6471ce6b92')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('b1d49e946babf5f26be5a4b1b4f36bbf3ae3ac5118ca56b1f9adff1dda37d9c3')
-build() {
- cd "${srcdir}/ppx_jane-v${pkgver}"
+_sourcedirectory="$_projectname-$pkgver"
- jbuilder build
+build() {
+ cd "$srcdir/$_sourcedirectory/"
+ dune build -p "$_projectname" --verbose
}
package() {
- cd "${srcdir}/ppx_jane-v${pkgver}"
+ cd "$srcdir/$_sourcedirectory/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
+ rm -r "$pkgdir/usr/doc/"
- install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
- mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
}