summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2018-06-28 17:26:38 +0200
committerJakob Gahde2018-06-28 17:26:38 +0200
commita28b2796c47ec1e87acf00b0eb2a38c451cefaaa (patch)
tree2cc240ba4f72518435f65294cf75cea4cceba9cd
downloadaur-a28b2796c47ec1e87acf00b0eb2a38c451cefaaa.tar.gz
ocaml-ppx_js_style 0.11.0-1: New package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d1b333c041b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Jun 28 15:26:21 UTC 2018
+pkgbase = ocaml-ppx_js_style
+ pkgdesc = Code style checker for Jane Street Packages
+ pkgver = 0.11.0
+ pkgrel = 1
+ url = https://github.com/janestreet/ppx_js_style
+ arch = x86_64
+ license = Apache
+ makedepends = dune
+ depends = ocaml
+ depends = ocaml-base
+ depends = ocaml-migrate-parsetree
+ depends = ocaml-octavius
+ depends = ocaml-ppxlib
+ options = !strip
+ source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/ppx_js_style-v0.11.0.tar.gz
+ md5sums = 0994a7ecf0468f13fcac660413afafad
+
+pkgname = ocaml-ppx_js_style
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e350ecb56989
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-ppx_js_style
+pkgver=0.11.0
+pkgrel=1
+pkgdesc="Code style checker for Jane Street Packages"
+arch=('x86_64')
+url='https://github.com/janestreet/ppx_js_style'
+license=('Apache')
+depends=('ocaml' 'ocaml-base' 'ocaml-migrate-parsetree' 'ocaml-octavius' 'ocaml-ppxlib')
+makedepends=('dune')
+options=('!strip')
+source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/ppx_js_style-v${pkgver}.tar.gz")
+md5sums=('0994a7ecf0468f13fcac660413afafad')
+
+build() {
+ cd "${srcdir}/ppx_js_style-v${pkgver}"
+
+ jbuilder build
+}
+
+
+package() {
+ cd "${srcdir}/ppx_js_style-v${pkgver}"
+
+ mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
+ jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+}