diff options
author | Daniel Peukert | 2024-01-28 00:12:00 +0100 |
---|---|---|
committer | Daniel Peukert | 2024-01-28 00:12:00 +0100 |
commit | 5a88b3f8d53a87b8e46367179d9c8a5b01cc4177 (patch) | |
tree | 92e3250f492697469e802cd9482cccff597c3fa0 | |
parent | 25bf9ed62f32853fc978766e8449ab200f9143eb (diff) | |
download | aur-5a88b3f8d53a87b8e46367179d9c8a5b01cc4177.tar.gz |
Sync pkgbuilds repo with AUR
-rw-r--r-- | .SRCINFO | 2 | ||||
-rw-r--r-- | .gitignore | 28 | ||||
-rw-r--r-- | PKGBUILD | 5 |
3 files changed, 17 insertions, 18 deletions
@@ -14,7 +14,7 @@ pkgbase = ocaml-ppx_module_timer depends = ocaml-stdio>=0.16.0 depends = ocaml-time_now>=0.16.0 options = !strip - source = ocaml-ppx_module_timer-0.16.0-1.tar.gz::https://github.com/janestreet/ppx_module_timer/archive/v0.16.0.tar.gz + source = ocaml-ppx_module_timer-0.16.0.tar.gz::https://github.com/janestreet/ppx_module_timer/archive/v0.16.0.tar.gz sha512sums = 6125aec05e91bb11d1b41fc4fb9a1030561403c7f27ea9d9512a6050da4cfdc796cfe3acb1d96e5333f65b6beab6f5b16b044529ccc6e99e90c019923adf85d9 pkgname = ocaml-ppx_module_timer diff --git a/.gitignore b/.gitignore index 82b3c183d5d4..076d904dd4ac 100644 --- a/.gitignore +++ b/.gitignore @@ -1,14 +1,14 @@ -# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore -*.tar -*.tar.* -*.rpm -*.jar -*.exe -*.msi -*.zip -*.tgz -*.log -*.log.* -*.sig - -*/ +# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo, +# which causes the gitignore file to apply to them too, which breaks some builds +# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore +/*.tar +/*.tar.* +/*.rpm +/*.jar +/*.exe +/*.msi +/*.zip +/*.tgz +/*.log +/*.log.* +/*.sig @@ -4,14 +4,13 @@ pkgname="ocaml-$_projectname" pkgver='0.16.0' pkgrel='1' pkgdesc='Ppx rewriter that records top-level module startup times' -# If you're running on aarch64, you have to add it to the arch array of the ocaml-biniou, ocaml-easy-format and ocaml-yojson AUR dependencies arch=('x86_64' 'aarch64') url="https://github.com/janestreet/$_projectname" license=('MIT') depends=('ocaml>=4.14.0' 'ocaml-base>=0.16.0' 'ocaml-ppx_base>=0.16.0' 'ocaml-ppxlib>=0.28.0' 'ocaml-stdio>=0.16.0' 'ocaml-time_now>=0.16.0') makedepends=('dune>=2.0.0') options=('!strip') -source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz") +source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz") sha512sums=('6125aec05e91bb11d1b41fc4fb9a1030561403c7f27ea9d9512a6050da4cfdc796cfe3acb1d96e5333f65b6beab6f5b16b044529ccc6e99e90c019923adf85d9') _sourcedirectory="$_projectname-$pkgver" @@ -26,5 +25,5 @@ package() { DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose install -dm755 "$pkgdir/usr/share/licenses/$pkgname" - ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md" + ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/MIT" } |