summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-06-02 00:18:58 +0200
committerDaniel Peukert2020-06-02 00:18:58 +0200
commit8caca2b3436b12081141079d3a8c641c154c9f63 (patch)
tree2dc32b3e8add2359555b7f86cc1a4d1797209883
parentca936699008346b9a7917c1904ea7a3e5f7edeaa (diff)
downloadaur-8caca2b3436b12081141079d3a8c641c154c9f63.tar.gz
Updated janestreet packages
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bc19e3b4925..61265cc9bee6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ppx_sexp_conv
pkgdesc = Generation of S-expression conversion functions from type definitions
- pkgver = 0.13.0
- pkgrel = 2
+ pkgver = 0.14.0
+ pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_sexp_conv
arch = x86_64
@@ -11,13 +11,13 @@ pkgbase = ocaml-ppx_sexp_conv
arch = armv7h
arch = aarch64
license = MIT
- makedepends = dune>=1.5.1
+ makedepends = dune>=2.0.0
depends = ocaml>=4.04.2
- depends = ocaml-base>=0.13.0
- depends = ocaml-ppxlib>=0.9.0
- depends = ocaml-sexplib0>=0.13.0
+ depends = ocaml-base>=0.14.0
+ depends = ocaml-ppxlib>=0.11.0
+ depends = ocaml-sexplib0>=0.14.0
options = !strip
- source = ocaml-ppx_sexp_conv-1:0.13.0-2.tar.gz::https://github.com/janestreet/ppx_sexp_conv/archive/v0.13.0.tar.gz
- sha256sums = 15386e4f704d37ff8a7155dfbae17e60d771339f433494f66fc19dab308831b0
+ source = ocaml-ppx_sexp_conv-1:0.14.0-1.tar.gz::https://github.com/janestreet/ppx_sexp_conv/archive/v0.14.0.tar.gz
+ sha256sums = 4ec3e7999affd70689cdb6681e600cefa78032af2235733e6c012ac0b93e1dd6
pkgname = ocaml-ppx_sexp_conv
diff --git a/PKGBUILD b/PKGBUILD
index 9905801febdb..da9677650ca4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,29 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppx_sexp_conv'
pkgname="ocaml-$_projectname"
-pkgver='0.13.0'
-pkgrel='2'
+pkgver='0.14.0'
+pkgrel='1'
epoch='1'
pkgdesc='Generation of S-expression conversion functions from type definitions'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
-depends=('ocaml>=4.04.2' 'ocaml-base>=0.13.0' 'ocaml-ppxlib>=0.9.0' 'ocaml-sexplib0>=0.13.0')
-makedepends=('dune>=1.5.1')
+depends=('ocaml>=4.04.2' 'ocaml-base>=0.14.0' 'ocaml-ppxlib>=0.11.0' 'ocaml-sexplib0>=0.14.0')
+makedepends=('dune>=2.0.0')
options=('!strip')
source=("$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('15386e4f704d37ff8a7155dfbae17e60d771339f433494f66fc19dab308831b0')
+sha256sums=('4ec3e7999affd70689cdb6681e600cefa78032af2235733e6c012ac0b93e1dd6')
_sourcedirectory="$_projectname-$pkgver"
build() {
cd "$srcdir/$_sourcedirectory/"
- dune build -p "$_projectname" --verbose
+ dune build --release --verbose
}
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
install -dm755 "$pkgdir/usr/share/doc/$pkgname"
mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"