summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2018-06-28 16:26:49 +0200
committerJakob Gahde2018-06-28 16:26:49 +0200
commit5af27bf029f06513681e28542e28fa0051d32cf0 (patch)
tree25d45bc7563d2a43479cedb8edb2bdc55713f5a0
parentd4ab62bbb85927441bb9fe8a38be3ab58fa81527 (diff)
downloadaur-5af27bf029f06513681e28542e28fa0051d32cf0.tar.gz
ocaml-ppx_sexp_message 1:0.11.0-1: New version
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
-rw-r--r--exedir.patch10
-rw-r--r--libdir.patch36
4 files changed, 19 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43e06a9f0c51..1cf7267991b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,24 @@
# Generated by mksrcinfo v8
-# Tue Jun 6 12:31:21 UTC 2017
+# Thu Jun 28 14:26:28 UTC 2018
pkgbase = ocaml-ppx_sexp_message
pkgdesc = A ppx rewriter for easy construction of s-expressions
- pkgver = 113.33.03
+ pkgver = 0.11.0
pkgrel = 1
url = https://github.com/janestreet/ppx_sexp_message
arch = i686
arch = x86_64
license = Apache
- makedepends = ocaml-findlib
- makedepends = ocaml-js-build-tools
- makedepends = opam
+ makedepends = dune
depends = ocaml
- depends = ocaml-ppx_core
- depends = ocaml-ppx_driver
+ depends = ocaml-base
depends = ocaml-ppx_here
depends = ocaml-ppx_sexp_conv
- depends = ocaml-ppx_tools
+ depends = ocaml-migrate-parsetree
+ depends = ocaml-ppxlib
options = !strip
options = !emptydirs
- source = https://ocaml.janestreet.com/ocaml-core/113.33/files/ppx_sexp_message-113.33.03.tar.gz
- source = libdir.patch
- source = exedir.patch
- md5sums = 91b7c60217aa86d73b1cd33ec6909a2d
- md5sums = 7f0a951f1ac87385272ea7a6dd58762a
- md5sums = 8c2670c9ecd0c91d1d56d71957a44e99
+ source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/ppx_sexp_message-v0.11.0.tar.gz
+ md5sums = 2cec96bcf6f7c54ba79fe39fc9fc4d98
pkgname = ocaml-ppx_sexp_message
diff --git a/PKGBUILD b/PKGBUILD
index f332effef052..ba38231ed9a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,28 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_sexp_message
-pkgver=113.33.03
+pkgver=0.11.0
pkgrel=1
pkgdesc="A ppx rewriter for easy construction of s-expressions"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/ppx_sexp_message"
license=('Apache')
-depends=('ocaml' 'ocaml-ppx_core' 'ocaml-ppx_driver' 'ocaml-ppx_here' 'ocaml-ppx_sexp_conv' 'ocaml-ppx_tools')
-makedepends=('ocaml-findlib' 'ocaml-js-build-tools' 'opam')
+depends=('ocaml' 'ocaml-base' 'ocaml-ppx_here' 'ocaml-ppx_sexp_conv' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+makedepends=('dune')
options=('!strip' '!emptydirs')
-source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz"
- "libdir.patch"
- "exedir.patch")
-md5sums=('91b7c60217aa86d73b1cd33ec6909a2d'
- '7f0a951f1ac87385272ea7a6dd58762a'
- '8c2670c9ecd0c91d1d56d71957a44e99')
-
-prepare() {
- cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
-
- patch -Np1 < "${srcdir}/libdir.patch"
- patch -Np1 < "${srcdir}/exedir.patch"
-}
+source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/ppx_sexp_message-v${pkgver}.tar.gz")
+md5sums=('2cec96bcf6f7c54ba79fe39fc9fc4d98')
build() {
- cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+ cd "${srcdir}/ppx_sexp_message-v${pkgver}"
- ./configure --prefix=/usr
- make
+ jbuilder build
}
package() {
- cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+ cd "${srcdir}/ppx_sexp_message-v${pkgver}"
- make install PREFIX="${pkgdir}/usr" LIBDIR="${pkgdir}$(ocamlc -where)"
+ install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
+ jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}
diff --git a/exedir.patch b/exedir.patch
deleted file mode 100644
index 0a9253316369..000000000000
--- a/exedir.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -aur package.pristine/install.ml package.new/install.ml
---- package.pristine/install.ml 2016-07-29 15:07:39.147178212 +0200
-+++ package.new/install.ml 2016-07-29 15:07:50.557094559 +0200
-@@ -6,5 +6,5 @@
- generate ~package:"ppx_sexp_message"
- [ oasis_lib "ppx_sexp_message"
- ; file "META" ~section:"lib"
-- ; oasis_exe "ppx" ~dest:"../lib/ppx_sexp_message/ppx"
-+ ; oasis_exe "ppx" ~dest:"../lib/ocaml/ppx_sexp_message/ppx"
- ]
diff --git a/libdir.patch b/libdir.patch
deleted file mode 100644
index 6284fcd558b0..000000000000
--- a/libdir.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -aur package.pristine/Makefile package.new/Makefile
---- package.pristine/Makefile 2016-02-06 01:55:14.650150309 +0100
-+++ package.new/Makefile 2016-02-06 01:57:56.012174364 +0100
-@@ -29,26 +29,26 @@
- ocaml -I js-utils js-utils/gen_install.ml
-
- install: $(NAME).install
-- opam-installer -i --prefix $(PREFIX) $(NAME).install
-+ opam-installer -i --prefix $(PREFIX) --libdir $(LIBDIR) $(NAME).install
-
- uninstall: $(NAME).install
-- opam-installer -u --prefix $(PREFIX) $(NAME).install
-+ opam-installer -u --prefix $(PREFIX) --libdir $(LIBDIR) $(NAME).install
-
- reinstall: $(NAME).install
-- opam-installer -u --prefix $(PREFIX) $(NAME).install &> /dev/null || true
-- opam-installer -i --prefix $(PREFIX) $(NAME).install
-+ opam-installer -u --prefix $(PREFIX) --libdir $(LIBDIR) $(NAME).install &> /dev/null || true
-+ opam-installer -i --prefix $(PREFIX) --libdir $(LIBDIR) $(NAME).install
-
- bin.tar.gz: $(NAME).install
- rm -rf _install
- mkdir _install
-- opam-installer -i --prefix _install $(NAME).install
-+ opam-installer -i --prefix _install --libdir $(LIBDIR) $(NAME).install
- tar czf bin.tar.gz -C _install .
- rm -rf _install
-
- bin.lzo: $(NAME).install
- rm -rf _install
- mkdir _install
-- opam-installer -i --prefix _install $(NAME).install
-+ opam-installer -i --prefix _install --libdir $(LIBDIR) $(NAME).install
- cd _install && lzop -1 -P -o ../bin.lzo `find . -type f`
- rm -rf _install
-