summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-07-29 15:09:46 +0200
committerJakob Gahde2016-07-29 15:09:46 +0200
commite6813e9a80677cb61d16ae9e449a394b2cb1d003 (patch)
tree7f7d9a6cd0ff2d086a98056be382cad41a622037
parent30a481ba85f4d9ba02c3e1f858df2d01c20b93da (diff)
downloadaur-e6813e9a80677cb61d16ae9e449a394b2cb1d003.tar.gz
ocaml-ppx_sexp_message 113.33.03-1: New version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--exedir.patch10
3 files changed, 27 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb17efa339eb..bf8954b35612 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Sat Feb 6 03:19:39 UTC 2016
+# Fri Jul 29 13:09:29 UTC 2016
pkgbase = ocaml-ppx_sexp_message
pkgdesc = A ppx rewriter for easy construction of s-expressions
- pkgver = 113.24.00
+ pkgver = 113.33.03
pkgrel = 1
url = https://github.com/janestreet/ppx_sexp_message
arch = i686
arch = x86_64
license = Apache
makedepends = ocaml-findlib
+ makedepends = ocaml-js-build-tools
makedepends = opam
depends = ocaml
depends = ocaml-ppx_core
@@ -17,10 +18,13 @@ pkgbase = ocaml-ppx_sexp_message
depends = ocaml-ppx_sexp_conv
depends = ocaml-ppx_tools
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/113.24/files/ppx_sexp_message-113.24.00.tar.gz
+ options = !emptydirs
+ source = https://ocaml.janestreet.com/ocaml-core/113.33/files/ppx_sexp_message-113.33.03.tar.gz
source = libdir.patch
- md5sums = f4355b8c00f7337a3750c97c9edd8a3d
+ source = exedir.patch
+ md5sums = 91b7c60217aa86d73b1cd33ec6909a2d
md5sums = 7f0a951f1ac87385272ea7a6dd58762a
+ md5sums = 8c2670c9ecd0c91d1d56d71957a44e99
pkgname = ocaml-ppx_sexp_message
diff --git a/PKGBUILD b/PKGBUILD
index 9339a249c1bb..74a596e4d4de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_sexp_message
-pkgver=113.24.00
+pkgver=113.33.03
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="A ppx rewriter for easy construction of s-expressions"
url="https://github.com/janestreet/ppx_sexp_message"
depends=('ocaml' 'ocaml-ppx_core' 'ocaml-ppx_driver' 'ocaml-ppx_here' 'ocaml-ppx_sexp_conv' 'ocaml-ppx_tools')
-makedepends=('ocaml-findlib' 'opam')
+makedepends=('ocaml-findlib' 'ocaml-js-build-tools' 'opam')
source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz"
- "libdir.patch")
-options=('!strip')
-md5sums=('f4355b8c00f7337a3750c97c9edd8a3d'
- '7f0a951f1ac87385272ea7a6dd58762a')
+ "libdir.patch"
+ "exedir.patch")
+options=('!strip' '!emptydirs')
+md5sums=('91b7c60217aa86d73b1cd33ec6909a2d'
+ '7f0a951f1ac87385272ea7a6dd58762a'
+ '8c2670c9ecd0c91d1d56d71957a44e99')
prepare() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
patch -Np1 < "${srcdir}/libdir.patch"
+ patch -Np1 < "${srcdir}/exedir.patch"
}
build() {
diff --git a/exedir.patch b/exedir.patch
new file mode 100644
index 000000000000..0a9253316369
--- /dev/null
+++ b/exedir.patch
@@ -0,0 +1,10 @@
+diff -aur package.pristine/install.ml package.new/install.ml
+--- package.pristine/install.ml 2016-07-29 15:07:39.147178212 +0200
++++ package.new/install.ml 2016-07-29 15:07:50.557094559 +0200
+@@ -6,5 +6,5 @@
+ generate ~package:"ppx_sexp_message"
+ [ oasis_lib "ppx_sexp_message"
+ ; file "META" ~section:"lib"
+- ; oasis_exe "ppx" ~dest:"../lib/ppx_sexp_message/ppx"
++ ; oasis_exe "ppx" ~dest:"../lib/ocaml/ppx_sexp_message/ppx"
+ ]