summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-06-02 00:19:23 +0200
committerDaniel Peukert2020-06-02 00:19:23 +0200
commit2bc94fc63b0575c625c2cc7c1b82a32a5d43eef1 (patch)
treecc6688b91ce5fddfaee1f6034777c7588dce1223
parent34b1871733b56b9b8ac8bd93be8c907ab089995e (diff)
downloadaur-2bc94fc63b0575c625c2cc7c1b82a32a5d43eef1.tar.gz
Updated janestreet packages
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8369d9f1a03d..ec9bd987e87f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ppx_sexp_value
pkgdesc = A ppx rewriter that simplifies building s-expressions from ocaml values
- pkgver = 0.13.0
- pkgrel = 2
+ pkgver = 0.14.0
+ pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_sexp_value
arch = x86_64
@@ -11,14 +11,14 @@ pkgbase = ocaml-ppx_sexp_value
arch = armv7h
arch = aarch64
license = MIT
- makedepends = dune>=1.5.1
+ makedepends = dune>=2.0.0
depends = ocaml>=4.04.2
- depends = ocaml-base>=0.13.0
- depends = ocaml-ppx_here>=0.13.0
- depends = ocaml-ppx_sexp_conv>=0.13.0
- depends = ocaml-ppxlib>=0.9.0
+ depends = ocaml-base>=0.14.0
+ depends = ocaml-ppx_here>=0.14.0
+ depends = ocaml-ppx_sexp_conv>=0.14.0
+ depends = ocaml-ppxlib>=0.11.0
options = !strip
- source = ocaml-ppx_sexp_value-1:0.13.0-2.tar.gz::https://github.com/janestreet/ppx_sexp_value/archive/v0.13.0.tar.gz
- sha256sums = 545fba8db3b16d22bef78d2dedcf3e90422cf4f6f9184c008c4326671c58e897
+ source = ocaml-ppx_sexp_value-1:0.14.0-1.tar.gz::https://github.com/janestreet/ppx_sexp_value/archive/v0.14.0.tar.gz
+ sha256sums = 7cf65018a3c5260a1ea1fb4f483bdb0a5269598a86e454a04e74ef5628f0b9bc
pkgname = ocaml-ppx_sexp_value
diff --git a/PKGBUILD b/PKGBUILD
index 7f05e03360e5..e6204d300bca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,29 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppx_sexp_value'
pkgname="ocaml-$_projectname"
-pkgver='0.13.0'
-pkgrel='2'
+pkgver='0.14.0'
+pkgrel='1'
epoch='1'
pkgdesc='A ppx rewriter that simplifies building s-expressions from ocaml values'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
-depends=('ocaml>=4.04.2' 'ocaml-base>=0.13.0' 'ocaml-ppx_here>=0.13.0' 'ocaml-ppx_sexp_conv>=0.13.0' 'ocaml-ppxlib>=0.9.0')
-makedepends=('dune>=1.5.1')
+depends=('ocaml>=4.04.2' 'ocaml-base>=0.14.0' 'ocaml-ppx_here>=0.14.0' 'ocaml-ppx_sexp_conv>=0.14.0' 'ocaml-ppxlib>=0.11.0')
+makedepends=('dune>=2.0.0')
options=('!strip')
source=("$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('545fba8db3b16d22bef78d2dedcf3e90422cf4f6f9184c008c4326671c58e897')
+sha256sums=('7cf65018a3c5260a1ea1fb4f483bdb0a5269598a86e454a04e74ef5628f0b9bc')
_sourcedirectory="$_projectname-$pkgver"
build() {
cd "$srcdir/$_sourcedirectory/"
- dune build -p "$_projectname" --verbose
+ dune build --release --verbose
}
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
install -dm755 "$pkgdir/usr/share/doc/$pkgname"
mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"