summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:12:55 +0100
committerDaniel Peukert2024-01-28 00:12:55 +0100
commit112b5137827158b5e42aff63c4123c2bc430acbb (patch)
tree7d598e1988930412ac67ce4d471526a561fb4dec
parentb60b1d768cb0e01be3da33ca779e432ed6c4de1a (diff)
downloadaur-112b5137827158b5e42aff63c4123c2bc430acbb.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD5
3 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07f89e118de9..6ebdd8496917 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = ocaml-ppx_string
depends = ocaml-ppx_base>=0.16.0
depends = ocaml-ppxlib>=0.28.0
options = !strip
- source = ocaml-ppx_string-0.16.0-1.tar.gz::https://github.com/janestreet/ppx_string/archive/v0.16.0.tar.gz
+ source = ocaml-ppx_string-0.16.0.tar.gz::https://github.com/janestreet/ppx_string/archive/v0.16.0.tar.gz
sha512sums = b1310551e1548fee5b99e64635139189139791f2ea2da93a4751b04c78a5519c5f3833c515d93a25e9d7aa23945414cbe690e5cd3f34630cdca4819c3d8ec1bc
pkgname = ocaml-ppx_string
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index d62b5862dd47..82025078f10a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,13 @@ pkgname="ocaml-$_projectname"
pkgver='0.16.0'
pkgrel='1'
pkgdesc='Ppx extension for string interpolation'
-# If you're running on aarch64, you have to add it to the arch array of the ocaml-biniou, ocaml-easy-format and ocaml-yojson AUR dependencies
arch=('x86_64' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
depends=('ocaml>=4.14.0' 'ocaml-base>=0.16.0' 'ocaml-ppx_base>=0.16.0' 'ocaml-ppxlib>=0.28.0')
makedepends=('dune>=2.0.0')
options=('!strip')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha512sums=('b1310551e1548fee5b99e64635139189139791f2ea2da93a4751b04c78a5519c5f3833c515d93a25e9d7aa23945414cbe690e5cd3f34630cdca4819c3d8ec1bc')
_sourcedirectory="$_projectname-$pkgver"
@@ -26,5 +25,5 @@ package() {
DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/MIT"
}