summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-07-12 13:27:12 +0200
committerJ5lx2015-07-12 13:27:12 +0200
commit06ceeb9d3a802ccd4c9c3304d5cec14df6725872 (patch)
treee0025e666e3b7b39e127c390eafdec0bbab82927
downloadaur-06ceeb9d3a802ccd4c9c3304d5cec14df6725872.tar.gz
0.99.2-1: Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d9c58ab8403
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ocaml-ppx_tools
+ pkgdesc = Tools for authors of ppx rewriters and other syntactic tools
+ pkgver = 0.99.2
+ pkgrel = 1
+ url = https://github.com/alainfrisch/ppx_tools
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = ocaml-findlib
+ depends = ocaml
+ source = https://github.com/alainfrisch/ppx_tools/archive/ppx_tools_0.99.2.tar.gz
+ md5sums = 94926dda74fa4720d4d3edac57ba5fee
+
+pkgname = ocaml-ppx_tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48486b98f847
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+_pkgname=ppx_tools
+pkgname=ocaml-${_pkgname}
+pkgver=0.99.2
+pkgrel=1
+pkgdesc="Tools for authors of ppx rewriters and other syntactic tools"
+arch=('i686' 'x86_64')
+url="https://github.com/alainfrisch/ppx_tools"
+license=('MIT')
+depends=('ocaml')
+makedepends=('ocaml-findlib')
+source=("https://github.com/alainfrisch/${_pkgname}/archive/${_pkgname}_${pkgver}.tar.gz")
+md5sums=('94926dda74fa4720d4d3edac57ba5fee')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${_pkgname}_${pkgver}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${_pkgname}_${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}"
+
+ make install
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}