summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2017-03-19 16:33:09 +0100
committerJakob Gahde2017-03-19 16:33:09 +0100
commita5eca5ce18e9e87fe258f80f8a50228d5bc320e8 (patch)
tree13f9e2b782c36c06ee051c743ac6a0e53b7afafa
parentcbdd255807e5f406b9ad626924ff95730c98abe0 (diff)
downloadaur-a5eca5ce18e9e87fe258f80f8a50228d5bc320e8.tar.gz
ocaml-ppx_tools 5.0+4.04.0-1: Update for OCaml 4.04
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 27 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0dc9839ee2ad..cf41edf3fa23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Oct 31 14:01:31 UTC 2016
+# Sun Mar 19 15:32:28 UTC 2017
pkgbase = ocaml-ppx_tools
pkgdesc = Tools for authors of ppx rewriters and other syntactic tools
- pkgver = 5.0+4.03.0
+ pkgver = 5.0+4.04.0
pkgrel = 1
url = https://github.com/alainfrisch/ppx_tools
arch = i686
@@ -10,8 +10,12 @@ pkgbase = ocaml-ppx_tools
license = MIT
makedepends = ocaml-findlib
depends = ocaml
- source = https://github.com/alainfrisch/ppx_tools/archive/5.0+4.03.0.tar.gz
- md5sums = 5ca9f031ca0b2e986fc8e3514dfd70d9
+ source = https://github.com/alainfrisch/ppx_tools/archive/5.0.tar.gz
+ source = https://github.com/alainfrisch/ppx_tools/commit/881a4826a4da482ceeca262950c5a8a0ca4e11d4.patch
+ source = https://github.com/alainfrisch/ppx_tools/commit/f70ca1d07d565989a0041e312e8efc00ff2ad87e.patch
+ md5sums = 0ebba4648f519665c91450081cde976a
+ md5sums = eeccea12d66b3b3642f75a17cb9636f2
+ md5sums = bb622110bf23d30e9022e4bf915a5524
pkgname = ocaml-ppx_tools
diff --git a/PKGBUILD b/PKGBUILD
index 3a436057f4fc..b488f9ffa3c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,9 @@
_pkgname=ppx_tools
pkgname=ocaml-${_pkgname}
-pkgver=5.0+4.03.0
+_pkgver=5.0
+_ocamlver=4.04.0
+pkgver=${_pkgver}+${_ocamlver}
pkgrel=1
pkgdesc="Tools for authors of ppx rewriters and other syntactic tools"
arch=('i686' 'x86_64')
@@ -10,17 +12,29 @@ url="https://github.com/alainfrisch/ppx_tools"
license=('MIT')
depends=('ocaml')
makedepends=('ocaml-findlib')
-source=("https://github.com/alainfrisch/${_pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('5ca9f031ca0b2e986fc8e3514dfd70d9')
+source=("https://github.com/alainfrisch/${_pkgname}/archive/${_pkgver}.tar.gz"
+ "https://github.com/alainfrisch/ppx_tools/commit/881a4826a4da482ceeca262950c5a8a0ca4e11d4.patch"
+ "https://github.com/alainfrisch/ppx_tools/commit/f70ca1d07d565989a0041e312e8efc00ff2ad87e.patch")
+md5sums=('0ebba4648f519665c91450081cde976a'
+ 'eeccea12d66b3b3642f75a17cb9636f2'
+ 'bb622110bf23d30e9022e4bf915a5524')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${_pkgver}"
+
+ # Fix compilation with OCaml 4.04
+ patch -Np1 < "${srcdir}/881a4826a4da482ceeca262950c5a8a0ca4e11d4.patch"
+ patch -Np1 < "${srcdir}/f70ca1d07d565989a0041e312e8efc00ff2ad87e.patch"
+}
build() {
- cd "${srcdir}/${_pkgname}-${pkgver/+/-}"
+ cd "${srcdir}/${_pkgname}-${_pkgver}"
make
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver/+/-}"
+ cd "${srcdir}/${_pkgname}-${_pkgver}"
export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
install -dm755 "${OCAMLFIND_DESTDIR}"