summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-05-26 17:05:34 +0200
committerDaniel Peukert2020-05-26 17:05:34 +0200
commitd347ebce5ebf326bb5b95befb740391e5381d57e (patch)
tree966f22d6141d7ff94dbeb2c9777f09416cd5074d
parent729f9458a65259758953e253309d911fca8432b7 (diff)
downloadaur-d347ebce5ebf326bb5b95befb740391e5381d57e.tar.gz
Updated ocaml-ppx_tools to 6.1+4.10.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2472566742d..62099508b245 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ppx_tools
pkgdesc = Tools for authors of ppx rewriters and other syntactic tools
- pkgver = 6.0+4.08.0
- pkgrel = 3
+ pkgver = 6.1+4.10.0
+ pkgrel = 1
url = https://github.com/ocaml-ppx/ppx_tools
arch = x86_64
arch = i686
@@ -11,9 +11,9 @@ pkgbase = ocaml-ppx_tools
arch = aarch64
license = MIT
makedepends = dune>=1.6.0
- depends = ocaml>=4.08.0
+ depends = ocaml>=4.10.0
options = !strip
- source = ocaml-ppx_tools-6.0+4.08.0-3.tar.gz::https://github.com/ocaml-ppx/ppx_tools/archive/6.0+4.08.0.tar.gz
- sha256sums = d633d838c68ce9d01c572ea61072a524724116b8a6059c4f8b7a15010f772f8c
+ source = ocaml-ppx_tools-6.1+4.10.0-1.tar.gz::https://github.com/ocaml-ppx/ppx_tools/archive/6.1+4.10.0.tar.gz
+ sha256sums = 8fe028e66f5f5e644234386b0587100102a54de00f32e5c6de0aaa426e242fab
pkgname = ocaml-ppx_tools
diff --git a/PKGBUILD b/PKGBUILD
index d257334be95f..d54390832153 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,28 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppx_tools'
pkgname="ocaml-$_projectname"
-pkgver='6.0+4.08.0'
-pkgrel='3'
+pkgver='6.1+4.10.0'
+pkgrel='1'
pkgdesc='Tools for authors of ppx rewriters and other syntactic tools'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-ppx/$_projectname"
license=('MIT')
-depends=('ocaml>=4.08.0')
+depends=('ocaml>=4.10.0')
makedepends=('dune>=1.6.0')
options=('!strip')
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('d633d838c68ce9d01c572ea61072a524724116b8a6059c4f8b7a15010f772f8c')
+sha256sums=('8fe028e66f5f5e644234386b0587100102a54de00f32e5c6de0aaa426e242fab')
_sourcedirectory="$_projectname-$(printf '%s' "$pkgver" | tr '+' '-')"
build() {
cd "$srcdir/$_sourcedirectory/"
- dune build -p "$_projectname" --verbose
+ dune build --release --verbose
}
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
install -dm755 "$pkgdir/usr/share/doc/$pkgname"
mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"