summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2017-07-28 11:06:45 +0200
committerJakob Gahde2017-07-28 11:06:45 +0200
commitfb3e083b45d54ff11779525bb2e02f98442e0118 (patch)
treeacd0bf526e44b6f221361e667be81d6efb9740d3
parenta5eca5ce18e9e87fe258f80f8a50228d5bc320e8 (diff)
downloadaur-fb3e083b45d54ff11779525bb2e02f98442e0118.tar.gz
ocaml-ppx_tools 5.0+4.05.0-1: New version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 9 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf41edf3fa23..900cdc5c0e0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Mar 19 15:32:28 UTC 2017
+# Fri Jul 28 09:05:42 UTC 2017
pkgbase = ocaml-ppx_tools
pkgdesc = Tools for authors of ppx rewriters and other syntactic tools
- pkgver = 5.0+4.04.0
+ pkgver = 5.0+4.05.0
pkgrel = 1
url = https://github.com/alainfrisch/ppx_tools
arch = i686
@@ -10,12 +10,8 @@ pkgbase = ocaml-ppx_tools
license = MIT
makedepends = ocaml-findlib
depends = ocaml
- source = https://github.com/alainfrisch/ppx_tools/archive/5.0.tar.gz
- source = https://github.com/alainfrisch/ppx_tools/commit/881a4826a4da482ceeca262950c5a8a0ca4e11d4.patch
- source = https://github.com/alainfrisch/ppx_tools/commit/f70ca1d07d565989a0041e312e8efc00ff2ad87e.patch
- md5sums = 0ebba4648f519665c91450081cde976a
- md5sums = eeccea12d66b3b3642f75a17cb9636f2
- md5sums = bb622110bf23d30e9022e4bf915a5524
+ source = https://github.com/alainfrisch/ppx_tools/archive/5.0+4.05.0.tar.gz
+ md5sums = cf455545d5df2ed447a101f1d44454e9
pkgname = ocaml-ppx_tools
diff --git a/PKGBUILD b/PKGBUILD
index b488f9ffa3c4..aeac52466d9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,7 @@
_pkgname=ppx_tools
pkgname=ocaml-${_pkgname}
-_pkgver=5.0
-_ocamlver=4.04.0
-pkgver=${_pkgver}+${_ocamlver}
+pkgver=5.0+4.05.0
pkgrel=1
pkgdesc="Tools for authors of ppx rewriters and other syntactic tools"
arch=('i686' 'x86_64')
@@ -12,29 +10,17 @@ url="https://github.com/alainfrisch/ppx_tools"
license=('MIT')
depends=('ocaml')
makedepends=('ocaml-findlib')
-source=("https://github.com/alainfrisch/${_pkgname}/archive/${_pkgver}.tar.gz"
- "https://github.com/alainfrisch/ppx_tools/commit/881a4826a4da482ceeca262950c5a8a0ca4e11d4.patch"
- "https://github.com/alainfrisch/ppx_tools/commit/f70ca1d07d565989a0041e312e8efc00ff2ad87e.patch")
-md5sums=('0ebba4648f519665c91450081cde976a'
- 'eeccea12d66b3b3642f75a17cb9636f2'
- 'bb622110bf23d30e9022e4bf915a5524')
-
-prepare() {
- cd "${srcdir}/${_pkgname}-${_pkgver}"
-
- # Fix compilation with OCaml 4.04
- patch -Np1 < "${srcdir}/881a4826a4da482ceeca262950c5a8a0ca4e11d4.patch"
- patch -Np1 < "${srcdir}/f70ca1d07d565989a0041e312e8efc00ff2ad87e.patch"
-}
+source=("https://github.com/alainfrisch/${_pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('cf455545d5df2ed447a101f1d44454e9')
build() {
- cd "${srcdir}/${_pkgname}-${_pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver/+/-}"
make
}
package() {
- cd "${srcdir}/${_pkgname}-${_pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver/+/-}"
export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
install -dm755 "${OCAMLFIND_DESTDIR}"