summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMort Yao2019-10-19 18:52:24 +0200
committerMort Yao2019-10-19 18:52:24 +0200
commit8a82fb267fff16d75f8729dabef43c2de5545cbe (patch)
treef4639d2bb464e2d853798eefc20f460fab02220b
downloadaur-8a82fb267fff16d75f8729dabef43c2de5545cbe.tar.gz
ocaml-ppx_tools-git 20190719-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7d25009c434
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Oct 19 16:52:05 UTC 2019
+pkgbase = ocaml-ppx_tools-git
+ pkgdesc = Tools for authors of ppx rewriters and other syntactic tools
+ pkgver = 20190719
+ pkgrel = 1
+ url = https://github.com/ocaml-ppx/ppx_tools
+ arch = x86_64
+ license = MIT
+ makedepends = ocaml-findlib
+ depends = ocaml
+ provides = ocaml-ppx_tools
+ conflicts = ocaml-ppx_tools
+ source = ocaml-ppx_tools-git::git://github.com/ocaml-ppx/ppx_tools.git
+ md5sums = SKIP
+
+pkgname = ocaml-ppx_tools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a1e64bcb9e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Mort Yao <soi@mort.ninja>
+
+pkgname=ocaml-ppx_tools-git
+pkgver=20190719
+pkgrel=1
+pkgdesc="Tools for authors of ppx rewriters and other syntactic tools"
+arch=('x86_64')
+url='https://github.com/ocaml-ppx/ppx_tools'
+license=('MIT')
+provides=('ocaml-ppx_tools')
+conflicts=('ocaml-ppx_tools')
+depends=('ocaml')
+makedepends=('ocaml-findlib')
+source=("${pkgname}::git://github.com/ocaml-ppx/ppx_tools.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git log -1 --pretty=format:%cd --date=short | sed 's/-//g'
+}
+
+build() {
+ cd "$pkgname"
+
+ make -j1
+}
+
+package() {
+ cd "$pkgname"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ install -dm755 "${OCAMLFIND_DESTDIR}"
+ make install
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}