summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-03-21 21:32:24 +0100
committerDaniel Peukert2020-03-21 21:32:24 +0100
commit7fee079047c0ee43739a11eb11fa5fe0acc3a2a6 (patch)
tree1b2f754863634d8bc186a22f8b91d55317ade32b
parent010ae70da9bb7e6626360ec9af18c37604a52257 (diff)
downloadaur-7fee079047c0ee43739a11eb11fa5fe0acc3a2a6.tar.gz
Added ocaml-ppx_jane and the rest of its dependencies
-rw-r--r--.SRCINFO28
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD48
4 files changed, 63 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b779659a3263..62e7bf53d375 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
-# Generated by mksrcinfo v8
-# Thu Jun 28 17:26:37 UTC 2018
pkgbase = ocaml-ppx_typerep_conv
pkgdesc = Generation of runtime types from type declarations
- pkgver = 0.11.1
+ pkgver = 0.13.0
pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_typerep_conv
- arch = i686
arch = x86_64
- license = Apache
- makedepends = dune
- depends = ocaml
- depends = ocaml-base
- depends = ocaml-typerep
- depends = ocaml-migrate-parsetree
- depends = ocaml-ppxlib
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = dune>=1.5.1
+ depends = ocaml>=4.04.2
+ depends = ocaml-base>=0.13.0
+ depends = ocaml-typerep>=0.13.0
+ depends = ocaml-ppxlib>=0.9.0
options = !strip
- source = https://github.com/janestreet/ppx_typerep_conv/archive/v0.11.1.tar.gz
- md5sums = 826e9daf00258184e3392c970fa7d616
+ source = ocaml-ppx_typerep_conv-0.13.0-1.tar.gz::https://github.com/janestreet/ppx_typerep_conv/archive/v0.13.0.tar.gz
+ sha256sums = 1f9a98d523e04881dfdfb175cc1b26ab1f758c4c57325583541004dc1793de92
pkgname = ocaml-ppx_typerep_conv
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index 346837a8d048..2a8222251b90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,35 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
-
-pkgname=ocaml-ppx_typerep_conv
-pkgver=0.11.1
-pkgrel=1
-epoch=1
-pkgdesc="Generation of runtime types from type declarations"
-arch=('i686' 'x86_64')
-url="https://github.com/janestreet/ppx_typerep_conv"
-license=('Apache')
-depends=('ocaml' 'ocaml-base' 'ocaml-typerep' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
-makedepends=('dune')
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
+_projectname='ppx_typerep_conv'
+pkgname="ocaml-$_projectname"
+pkgver='0.13.0'
+pkgrel='1'
+epoch='1'
+pkgdesc='Generation of runtime types from type declarations'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/janestreet/$_projectname"
+license=('MIT')
+depends=('ocaml>=4.04.2' 'ocaml-base>=0.13.0' 'ocaml-typerep>=0.13.0' 'ocaml-ppxlib>=0.9.0')
+makedepends=('dune>=1.5.1')
options=('!strip')
-source=("https://github.com/janestreet/ppx_typerep_conv/archive/v${pkgver}.tar.gz")
-md5sums=('826e9daf00258184e3392c970fa7d616')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('1f9a98d523e04881dfdfb175cc1b26ab1f758c4c57325583541004dc1793de92')
-build() {
- cd "${srcdir}/ppx_typerep_conv-${pkgver}"
+_sourcedirectory="$_projectname-$pkgver"
- jbuilder build
+build() {
+ cd "$srcdir/$_sourcedirectory/"
+ dune build -p "$_projectname" --verbose
}
package() {
- cd "${srcdir}/ppx_typerep_conv-${pkgver}"
+ cd "$srcdir/$_sourcedirectory/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
+ rm -r "$pkgdir/usr/doc/"
- install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
- mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
}