summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2021-03-01 03:10:29 +0100
committerDaniel Peukert2021-03-01 03:10:29 +0100
commit9c1259fc4b45f441dd122f14c62d284f467c002e (patch)
tree0352bebd69d9abbd78c948fa797da68cc723164d
parent21e075435f07e02f84db5967d7fa6e367d0c8e86 (diff)
downloadaur-9c1259fc4b45f441dd122f14c62d284f467c002e.tar.gz
Update ocaml-ppx_typerep_conv to 0.14.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
-rw-r--r--ppxlib.diff22
3 files changed, 10 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b62c295275f..7d8b96992b70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ppx_typerep_conv
pkgdesc = Generation of runtime types from type declarations
- pkgver = 0.14.1
- pkgrel = 3
+ pkgver = 0.14.2
+ pkgrel = 1
epoch = 1
url = https://github.com/janestreet/ppx_typerep_conv
arch = x86_64
@@ -15,11 +15,9 @@ pkgbase = ocaml-ppx_typerep_conv
depends = ocaml>=4.04.2
depends = ocaml-base>=0.14.0
depends = ocaml-typerep>=0.14.0
- depends = ocaml-ppxlib>=0.14.0
+ depends = ocaml-ppxlib>=0.22.0
options = !strip
- source = ocaml-ppx_typerep_conv-1:0.14.1-3.tar.gz::https://github.com/janestreet/ppx_typerep_conv/archive/v0.14.1.tar.gz
- source = ppxlib.diff
- sha256sums = 92e58fec59e83b972b53b4c72b1202192beaf83c53560357d05c948e4867dc14
- sha256sums = cc1f89a36a0965124b12f732a69a5121b88a0e8148f848c164ca733068c6287b
+ source = ocaml-ppx_typerep_conv-1:0.14.2-1.tar.gz::https://github.com/janestreet/ppx_typerep_conv/archive/v0.14.2.tar.gz
+ sha256sums = 1670dc267cacc8ea27a0b3aab4c08ed13fd622280e8169b93cea329def583abc
pkgname = ocaml-ppx_typerep_conv
diff --git a/PKGBUILD b/PKGBUILD
index a4ed530faffd..09ddfb3d5d85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,21 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppx_typerep_conv'
pkgname="ocaml-$_projectname"
-pkgver='0.14.1'
-pkgrel='3'
+pkgver='0.14.2'
+pkgrel='1'
epoch='1'
pkgdesc='Generation of runtime types from type declarations'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
-depends=('ocaml>=4.04.2' 'ocaml-base>=0.14.0' 'ocaml-typerep>=0.14.0' 'ocaml-ppxlib>=0.14.0')
+depends=('ocaml>=4.04.2' 'ocaml-base>=0.14.0' 'ocaml-typerep>=0.14.0' 'ocaml-ppxlib>=0.22.0')
makedepends=('dune>=2.0.0')
options=('!strip')
-source=(
- "$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz"
- "ppxlib.diff"
-)
-sha256sums=('92e58fec59e83b972b53b4c72b1202192beaf83c53560357d05c948e4867dc14'
- 'cc1f89a36a0965124b12f732a69a5121b88a0e8148f848c164ca733068c6287b')
+source=("$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('1670dc267cacc8ea27a0b3aab4c08ed13fd622280e8169b93cea329def583abc')
_sourcedirectory="$_projectname-$pkgver"
-prepare() {
- cd "$srcdir/$_sourcedirectory/"
- patch --forward -p1 < '../ppxlib.diff'
-}
-
build() {
cd "$srcdir/$_sourcedirectory/"
dune build --release --verbose
diff --git a/ppxlib.diff b/ppxlib.diff
deleted file mode 100644
index 25013c466fa7..000000000000
--- a/ppxlib.diff
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/src/ppx_typerep_conv.ml b/src/ppx_typerep_conv.ml
-index 6e92817..15fa079 100644
---- a/src/ppx_typerep_conv.ml
-+++ b/src/ppx_typerep_conv.ml
-@@ -184,7 +184,7 @@ module Typerep_implementation = struct
-
- val arg_of_param : string -> string
-
-- val params_names : params:(core_type * variance) list -> string list
-+ val params_names : params:(core_type * (variance * injectivity)) list -> string list
- val params_patts : loc:Location.t -> params_names:string list -> pattern list
-
- val type_name_module_definition : loc:Location.t -> path:string ->
-@@ -233,7 +233,7 @@ module Typerep_implementation = struct
- let str_item_type_and_name ~loc ~path ~params_names ~type_name =
- let params =
- List.map params_names
-- ~f:(fun name -> (ptyp_var ~loc name, Invariant))
-+ ~f:(fun name -> (ptyp_var ~loc name, (NoVariance, NoInjectivity)))
- in
- let td =
- let manifest =