summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-03-15 10:23:56 +0100
committerDaniel Peukert2020-03-15 10:23:56 +0100
commitea94871a003242e923ff9fd4f0db163e3793a243 (patch)
tree45344e1e20a5c8f65bcdca2f7f7341905dcd11f0
downloadaur-ea94871a003242e923ff9fd4f0db163e3793a243.tar.gz
Added ocaml-ppx_deriving and dependencies
-rw-r--r--.SRCINFO23
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD44
-rw-r--r--dune-version.diff10
5 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..432fb39e3467
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ocaml-ppxfind
+ pkgdesc = Tool combining ocamlfind and ppx
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://github.com/diml/ppxfind
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = dune
+ depends = ocaml>=4.02.3
+ depends = ocaml-findlib
+ depends = ocaml-migrate-parsetree
+ options = !strip
+ source = ocaml-ppxfind-1.4-1.tar.gz::https://github.com/diml/ppxfind/archive/1.4.tar.gz
+ source = dune-version.diff
+ sha256sums = 49e2f5cb7fb31e8fc2d482097d1bc96c8915ab50ea37133366da03a9a5ca3604
+ sha256sums = 5c589918a6f98fbb962590276629e4639037c02aaabdb10f5ec18b40ee2767c2
+
+pkgname = ocaml-ppxfind
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..863a433b129e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
+_projectname='ppxfind'
+pkgname="ocaml-$_projectname"
+pkgver='1.4'
+pkgrel='1'
+pkgdesc='Tool combining ocamlfind and ppx'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/diml/$_projectname"
+license=('MIT')
+depends=('ocaml>=4.02.3' 'ocaml-findlib' 'ocaml-migrate-parsetree')
+makedepends=('dune')
+options=('!strip')
+source=(
+ "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
+ 'dune-version.diff'
+)
+sha256sums=('49e2f5cb7fb31e8fc2d482097d1bc96c8915ab50ea37133366da03a9a5ca3604'
+ '5c589918a6f98fbb962590276629e4639037c02aaabdb10f5ec18b40ee2767c2')
+
+_sourcedirectory="$_projectname-$pkgver"
+
+prepare() {
+ cd "$srcdir/$_sourcedirectory/"
+ # Needed until Arch upgrades to dune>=2.0.0
+ patch --forward -p1 < '../dune-version.diff'
+}
+
+build() {
+ cd "$srcdir/$_sourcedirectory/"
+ dune build -p "$_projectname" --verbose
+}
+
+package() {
+ cd "$srcdir/$_sourcedirectory/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
+ rm -r "$pkgdir/usr/doc/"
+
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+}
diff --git a/dune-version.diff b/dune-version.diff
new file mode 100644
index 000000000000..98edb517eb70
--- /dev/null
+++ b/dune-version.diff
@@ -0,0 +1,10 @@
+diff --git a/dune-project b/dune-project
+index da918fc..f589040 100644
+--- a/dune-project
++++ b/dune-project
+@@ -1,4 +1,4 @@
+-(lang dune 2.0)
++(lang dune 1.11)
+ (name ppxfind)
+
+ (license BSD3)