summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMort Yao2018-05-19 00:17:18 +0200
committerMort Yao2018-05-19 00:17:18 +0200
commit7aef128e735163be0fbb9243724da2ed5a925fb9 (patch)
tree722f13a768ecb0ddb2ce30e52b29c35a98596951
downloadaur-7aef128e735163be0fbb9243724da2ed5a925fb9.tar.gz
ocaml-ppxfind-git 20171213-1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD33
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e457aa19be43
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri May 18 22:16:57 UTC 2018
+pkgbase = ocaml-ppxfind-git
+ pkgdesc = ocamlfind ppx tool
+ pkgver = 20171213
+ pkgrel = 1
+ url = https://github.com/diml/ppxfind
+ arch = x86_64
+ license = ISC
+ makedepends = ocamlbuild
+ makedepends = ocaml-findlib
+ provides = ocaml-ppxfind
+ source = ocaml-ppxfind-git::git://github.com/diml/ppxfind.git
+ md5sums = SKIP
+
+pkgname = ocaml-ppxfind-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..11046d3c70fe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+/pkg
+/src
+*.sig
+*.bz2
+*.gz
+*.tar
+*.xz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32a7dc6de28e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Mort Yao <soi@mort.ninja>
+
+pkgname=ocaml-ppxfind-git
+pkgver=20171213
+pkgrel=1
+pkgdesc="ocamlfind ppx tool"
+arch=('x86_64')
+url='https://github.com/diml/ppxfind'
+license=('ISC')
+provides=('ocaml-ppxfind')
+makedepends=('ocamlbuild' 'ocaml-findlib')
+source=("${pkgname}::git://github.com/diml/ppxfind.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git log -1 --pretty=format:%cd --date=short | sed 's/-//g'
+}
+
+build() {
+ cd "$pkgname"
+
+ make
+}
+
+package() {
+ destdir="$pkgdir/$(ocamlfind printconf destdir)"
+
+ cd "$pkgname"
+
+ mkdir -p "${pkgdir}"/usr/bin/
+ cp _build/install/default/bin/ppxfind "${pkgdir}"/usr/bin/
+}