summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-10-13 01:57:45 +0200
committerDaniel Peukert2020-10-13 01:57:45 +0200
commit4217a8daeb0b989c5342a400620bbdc8296d761c (patch)
tree4c21b09c9c4826b703b6ecb75dc430b793dde474
parentcc1a30df09ca622beae91b9443d4ba91da14eb93 (diff)
downloadaur-4217a8daeb0b989c5342a400620bbdc8296d761c.tar.gz
Updated ocaml-ppxlib to 0.18.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
-rw-r--r--ocaml-migrate-parsetree2.diff36
3 files changed, 28 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c631baebd6c4..0a88ca00f401 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ppxlib
pkgdesc = Standard library for ppx rewriters
- pkgver = 0.16.0
- pkgrel = 2
+ pkgver = 0.18.0
+ pkgrel = 1
url = https://github.com/ocaml-ppx/ppxlib
arch = x86_64
arch = i686
@@ -15,13 +15,12 @@ pkgbase = ocaml-ppxlib
depends = ocaml-compiler-libs-repackaged>=0.11.0
depends = ocaml-migrate-parsetree2
depends = ocaml-ppx_derivers>=1.0.0
- depends = ocaml-result
depends = ocaml-sexplib0
depends = ocaml-stdlib-shims
options = !strip
- source = ocaml-ppxlib-0.16.0-2.tar.gz::https://github.com/ocaml-ppx/ppxlib/archive/0.16.0.tar.gz
+ source = ocaml-ppxlib-0.18.0-1.tar.gz::https://github.com/ocaml-ppx/ppxlib/archive/0.18.0.tar.gz
source = ocaml-migrate-parsetree2.diff
- sha256sums = 67c9286f670d705caf588e8bb75665be06ccefc06001570dd3b00fdf44c6a6fc
- sha256sums = acb4e6dfeb0b0a67e23080eec2059fd15e2201a2f272e4eeca131eb750b7e9de
+ sha256sums = 64a9bfc78fa27b55a164ec5f37f74ca7843d0b94dd3f97d7bf2f7991cef470e4
+ sha256sums = bf1afe67407932df77f7cd786218e4fba45658586ec285e8988789e883281dac
pkgname = ocaml-ppxlib
diff --git a/PKGBUILD b/PKGBUILD
index f3959ca5ee60..7968d7c7d465 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppxlib'
pkgname="ocaml-$_projectname"
-pkgver='0.16.0'
-pkgrel='2'
+pkgver='0.18.0'
+pkgrel='1'
pkgdesc='Standard library for ppx rewriters'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-ppx/$_projectname"
license=('MIT')
-depends=('ocaml>=4.04.1' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-migrate-parsetree2' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-result' 'ocaml-sexplib0' 'ocaml-stdlib-shims')
+depends=('ocaml>=4.04.1' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-migrate-parsetree2' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-sexplib0' 'ocaml-stdlib-shims')
makedepends=('dune>=1.11.0')
options=('!strip')
source=(
"$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
'ocaml-migrate-parsetree2.diff'
)
-sha256sums=('67c9286f670d705caf588e8bb75665be06ccefc06001570dd3b00fdf44c6a6fc'
- 'acb4e6dfeb0b0a67e23080eec2059fd15e2201a2f272e4eeca131eb750b7e9de')
+sha256sums=('64a9bfc78fa27b55a164ec5f37f74ca7843d0b94dd3f97d7bf2f7991cef470e4'
+ 'bf1afe67407932df77f7cd786218e4fba45658586ec285e8988789e883281dac')
_sourcedirectory="$_projectname-$pkgver"
diff --git a/ocaml-migrate-parsetree2.diff b/ocaml-migrate-parsetree2.diff
index 3c3edca7f932..7c0365d00dbc 100644
--- a/ocaml-migrate-parsetree2.diff
+++ b/ocaml-migrate-parsetree2.diff
@@ -1,34 +1,34 @@
diff --git a/ast/ast_helper_lite.ml b/ast/ast_helper_lite.ml
-index f774f76..a362c98 100644
+index 11c6bbf..5f012e9 100644
--- a/ast/ast_helper_lite.ml
+++ b/ast/ast_helper_lite.ml
@@ -20,7 +20,7 @@ open Ocaml_common
module Location = Location
module Longident = Longident
-
--open Migrate_parsetree.Ast_410
-+open Migrate_parsetree2.Ast_410
-
+
+-open Migrate_parsetree.Ast_411
++open Migrate_parsetree2.Ast_411
+
[@@@warning "-9"]
open Asttypes
diff --git a/ast/ast_helper_lite.mli b/ast/ast_helper_lite.mli
-index 55ad921..216c1a4 100644
+index 99bdeef..d2678f5 100644
--- a/ast/ast_helper_lite.mli
+++ b/ast/ast_helper_lite.mli
@@ -16,7 +16,7 @@
(** Copy of Ast_helper from OCaml 4.10 with docstring related stuff removed *)
-
+
open Ocaml_common
--open Migrate_parsetree.Ast_410
-+open Migrate_parsetree2.Ast_410
-
+-open Migrate_parsetree.Ast_411
++open Migrate_parsetree2.Ast_411
+
open Asttypes
open Parsetree
diff --git a/ast/dune b/ast/dune
-index 08158a0..cc0f05c 100644
+index eefc483..4faecd5 100644
--- a/ast/dune
+++ b/ast/dune
-@@ -5,7 +5,7 @@
+@@ -9,7 +9,7 @@
ocaml-compiler-libs.shadow
ocaml-compiler-libs.common
compiler-libs.common
@@ -36,13 +36,13 @@ index 08158a0..cc0f05c 100644
+ ocaml-migrate-parsetree2
stdlib-shims)
(flags (:standard -open Ocaml_shadow -safe-string) -w -9-27-32)
- (preprocess (action (run %{exe:pp/pp.exe} %{ocaml_version} %{input-file})))
+ (preprocess
diff --git a/ast/versions.ml b/ast/versions.ml
index dbad548..2d08a0e 100644
--- a/ast/versions.ml
+++ b/ast/versions.ml
@@ -399,8 +399,8 @@ end
-
+
(*$ foreach_version (fun n version ->
printf "module OCaml_%d = struct\n" n;
- printf " module Ast = Migrate_parsetree.Ast_%d\n" n;
@@ -145,7 +145,7 @@ index dbad548..2d08a0e 100644
let string_version = "4.11"
end
@@ -482,27 +482,27 @@ let ocaml_411 : OCaml_411.types ocaml_version = (module OCaml_411)
-
+
(*$foreach_version_pair (fun a b ->
printf "include Register_migration(OCaml_%d)(OCaml_%d)\n" a b;
- printf " (Migrate_parsetree.Migrate_%d_%d)(Migrate_parsetree.Migrate_%d_%d)\n" a b b a
@@ -180,7 +180,7 @@ index dbad548..2d08a0e 100644
- (Migrate_parsetree.Migrate_410_411)(Migrate_parsetree.Migrate_411_410)
+ (Migrate_parsetree2.Migrate_410_411)(Migrate_parsetree2.Migrate_411_410)
(*$*)
-
+
module OCaml_current = OCaml_OCAML_VERSION
diff --git a/ast/versions.mli b/ast/versions.mli
index f36bef5..bc4fee8 100644
@@ -188,7 +188,7 @@ index f36bef5..bc4fee8 100644
+++ b/ast/versions.mli
@@ -112,19 +112,19 @@ end
(** {1 Concrete frontend instances} *)
-
+
(*$foreach_version (fun n _ ->
- printf "module OCaml_%d : OCaml_version with module Ast = Migrate_parsetree.Ast_%d\n"
+ printf "module OCaml_%d : OCaml_version with module Ast = Migrate_parsetree2.Ast_%d\n"
@@ -215,5 +215,5 @@ index f36bef5..bc4fee8 100644
+module OCaml_410 : OCaml_version with module Ast = Migrate_parsetree2.Ast_410
+module OCaml_411 : OCaml_version with module Ast = Migrate_parsetree2.Ast_411
(*$*)
-
+
(* An alias to the current compiler version *)