summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:11:47 +0100
committerDaniel Peukert2024-01-28 00:11:47 +0100
commit4dc8421dc6c86c16f68ead8dab9f33e511dc725b (patch)
treeff8392bef6c188e6c8b3aca4ddfdb5b3570abe77
parentae7a96e593dff9dd175f2cbb3fc3b46b09333244 (diff)
downloadaur-4dc8421dc6c86c16f68ead8dab9f33e511dc725b.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD2
2 files changed, 15 insertions, 15 deletions
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 47a797de6483..41c37532ba1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,5 +37,5 @@ package() {
done
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/MIT"
}