summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2018-06-28 01:39:18 +0200
committerJakob Gahde2018-06-28 01:39:18 +0200
commit5152c05d6d2e2368cc31bc79a77d717834e235ef (patch)
treee39ab9a0c0030157868530a749d8be046a695500
downloadaur-5152c05d6d2e2368cc31bc79a77d717834e235ef.tar.gz
ocaml-ppxlib 0.3.0-1: New package
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13ad4e882268
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Jun 27 23:38:56 UTC 2018
+pkgbase = ocaml-ppxlib
+ pkgdesc = Base library and tools for ppx rewriters
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/ocaml-ppx/ppxlib
+ arch = x86_64
+ license = MIT
+ makedepends = dune
+ depends = ocaml
+ depends = ocaml-base
+ depends = ocaml-compiler-libs-repackaged
+ depends = ocaml-migrate-parsetree
+ depends = ocaml-ppx_derivers
+ depends = ocaml-stdio
+ options = !strip
+ source = https://github.com/ocaml-ppx/ppxlib/archive/0.3.0.tar.gz
+ md5sums = e6ff83b1643a44fcb6b0acde4d2aa299
+
+pkgname = ocaml-ppxlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa9977676c69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-ppxlib
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Base library and tools for ppx rewriters"
+arch=('x86_64')
+url='https://github.com/ocaml-ppx/ppxlib'
+license=('MIT')
+depends=('ocaml' 'ocaml-base' 'ocaml-compiler-libs-repackaged' 'ocaml-migrate-parsetree' 'ocaml-ppx_derivers' 'ocaml-stdio')
+makedepends=('dune')
+options=('!strip')
+source=("https://github.com/ocaml-ppx/ppxlib/archive/${pkgver}.tar.gz")
+md5sums=('e6ff83b1643a44fcb6b0acde4d2aa299')
+
+build() {
+ cd "${srcdir}/ppxlib-${pkgver}"
+
+ jbuilder build
+}
+
+
+package() {
+ cd "${srcdir}/ppxlib-${pkgver}"
+
+ mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
+ jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -Dm755 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+}