summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-03-15 17:48:49 +0100
committerDaniel Peukert2020-03-15 17:48:49 +0100
commit6e118e84c37bd763e99f3b69dcc381edaab91d4e (patch)
treee5c150e85f0700ad8b6a33dc82481461b2b9f8a1
parentc065a27246c2db42ee0878519b809fff8742cd5e (diff)
downloadaur-6e118e84c37bd763e99f3b69dcc381edaab91d4e.tar.gz
Added ppx_let and dependencies
-rw-r--r--.SRCINFO24
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD49
4 files changed, 66 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11064e2721f7..578d855705ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
pkgbase = ocaml-ppxlib
pkgdesc = Base library and tools for ppx rewriters
- pkgver = 0.6.0
+ pkgver = 0.12.0
pkgrel = 1
url = https://github.com/ocaml-ppx/ppxlib
arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = MIT
makedepends = dune
- depends = ocaml
- depends = ocaml-base
- depends = ocaml-compiler-libs-repackaged
- depends = ocaml-migrate-parsetree
- depends = ocaml-ppx_derivers
- depends = ocaml-stdio
+ depends = ocaml>=4.04.1
+ depends = ocaml-base>=0.11.0
+ depends = ocaml-compiler-libs-repackaged>=0.11.0
+ depends = ocaml-migrate-parsetree>=1.3.1
+ depends = ocaml-ppx_derivers>=1.0.0
+ depends = ocaml-stdio>=0.11.0
options = !strip
- source = https://github.com/ocaml-ppx/ppxlib/releases/download/0.6.0/ppxlib-0.6.0.tbz
- sha512sums = dcb92285a4822499f66d86947cfcae25bbdbfec0df7c861c08cdcfe7b958dcb0ad6b42ca7737436150d0eebbaccc62d742fb37fc81c66c81e1d88b127654a06c
+ source = ocaml-ppxlib-0.12.0-1.tar.gz::https://github.com/ocaml-ppx/ppxlib/archive/0.12.0.tar.gz
+ sha256sums = 6b562c9b3b9350777318729921f890850b385c469db60769aafd9371998a2c42
pkgname = ocaml-ppxlib
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index cc02f7fdd5f2..1a31ed24d491 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,41 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
-
-pkgname=ocaml-ppxlib
-pkgver=0.6.0
-pkgrel=1
-pkgdesc="Base library and tools for ppx rewriters"
-arch=('x86_64')
-url='https://github.com/ocaml-ppx/ppxlib'
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
+_projectname='ppxlib'
+pkgname="ocaml-$_projectname"
+pkgver='0.12.0'
+pkgrel='1'
+pkgdesc='Base library and tools for ppx rewriters'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/ocaml-ppx/$_projectname"
license=('MIT')
-depends=('ocaml' 'ocaml-base' 'ocaml-compiler-libs-repackaged' 'ocaml-migrate-parsetree' 'ocaml-ppx_derivers' 'ocaml-stdio')
+depends=('ocaml>=4.04.1' 'ocaml-base>=0.11.0' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-migrate-parsetree>=1.3.1' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-stdio>=0.11.0')
makedepends=('dune')
+# checkdepends=('ocampl-cinaps>=0.12.1' 'ocaml-findlib')
options=('!strip')
-source=("https://github.com/ocaml-ppx/ppxlib/releases/download/${pkgver}/ppxlib-${pkgver}.tbz")
-sha512sums=('dcb92285a4822499f66d86947cfcae25bbdbfec0df7c861c08cdcfe7b958dcb0ad6b42ca7737436150d0eebbaccc62d742fb37fc81c66c81e1d88b127654a06c')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('6b562c9b3b9350777318729921f890850b385c469db60769aafd9371998a2c42')
-build() {
- cd "${srcdir}/ppxlib-${pkgver}"
+_sourcedirectory="$_projectname-$pkgver"
- dune build
+build() {
+ cd "$srcdir/$_sourcedirectory/"
+ dune build -p "$_projectname" --verbose
}
+# re-enable when ocaml-ppx_jane (dep of ocampl-cinaps) is updated
+# check() {
+# cd "$srcdir/$_sourcedirectory/"
+# dune runtest -p "$_projectname" --verbose
+# }
package() {
- cd "${srcdir}/ppxlib-${pkgver}"
+ cd "$srcdir/$_sourcedirectory/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
+ rm -r "$pkgdir/usr/doc/"
- mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
- dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
- mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
- install -Dm755 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
}