summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-03-21 21:46:43 +0100
committerDaniel Peukert2020-03-21 21:46:43 +0100
commita4fb1c389d624b392dd53d06d7f8498ad175d641 (patch)
tree36d1f8a8c732a1ee7e03540d5117bc690dbb7744
parent4907fce8d313f7212528f3f4d9d099ea53ba231d (diff)
downloadaur-a4fb1c389d624b392dd53d06d7f8498ad175d641.tar.gz
Enable tests for ocaml-ppxlib
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
2 files changed, 24 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3400ceb7d630..408b3208d154 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ppxlib
pkgdesc = Base library and tools for ppx rewriters
pkgver = 0.12.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ocaml-ppx/ppxlib
arch = x86_64
arch = i686
@@ -10,6 +10,8 @@ pkgbase = ocaml-ppxlib
arch = armv7h
arch = aarch64
license = MIT
+ checkdepends = ocaml-cinaps>=0.12.1
+ checkdepends = ocaml-findlib
makedepends = dune
depends = ocaml>=4.04.1
depends = ocaml-base>=0.11.0
@@ -18,7 +20,9 @@ pkgbase = ocaml-ppxlib
depends = ocaml-ppx_derivers>=1.0.0
depends = ocaml-stdio>=0.11.0
options = !strip
- source = ocaml-ppxlib-0.12.0-2.tar.gz::https://github.com/ocaml-ppx/ppxlib/archive/0.12.0.tar.gz
+ source = ocaml-ppxlib-0.12.0-3.tar.gz::https://github.com/ocaml-ppx/ppxlib/archive/0.12.0.tar.gz
+ source = ocaml-ppxlib-0.12.0-3-fix-tests.diff::https://github.com/ocaml-ppx/ppxlib/pull/111.diff
sha256sums = 6b562c9b3b9350777318729921f890850b385c469db60769aafd9371998a2c42
+ sha256sums = 891640f82db542e682d250547e1f39290b8a230b287fbcd0b22c2e43adaa6f64
pkgname = ocaml-ppxlib
diff --git a/PKGBUILD b/PKGBUILD
index e00d8f4fcd80..03a17d604b3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,39 @@
_projectname='ppxlib'
pkgname="ocaml-$_projectname"
pkgver='0.12.0'
-pkgrel='2'
+pkgrel='3'
pkgdesc='Base library and tools for ppx rewriters'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-ppx/$_projectname"
license=('MIT')
depends=('ocaml>=4.04.1' 'ocaml-base>=0.11.0' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-migrate-parsetree>=1.3.1' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-stdio>=0.11.0')
makedepends=('dune')
-# checkdepends=('ocampl-cinaps>=0.12.1' 'ocaml-findlib')
+checkdepends=('ocaml-cinaps>=0.12.1' 'ocaml-findlib')
options=('!strip')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('6b562c9b3b9350777318729921f890850b385c469db60769aafd9371998a2c42')
+source=(
+ "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
+ "$pkgname-$pkgver-$pkgrel-fix-tests.diff::$url/pull/111.diff"
+)
+sha256sums=('6b562c9b3b9350777318729921f890850b385c469db60769aafd9371998a2c42'
+ '891640f82db542e682d250547e1f39290b8a230b287fbcd0b22c2e43adaa6f64')
_sourcedirectory="$_projectname-$pkgver"
+prepare() {
+ cd "$srcdir/$_sourcedirectory/"
+ # https://github.com/ocaml-ppx/ppxlib/pull/111
+ patch --forward -p1 < "../$pkgname-$pkgver-$pkgrel-fix-tests.diff"
+}
+
build() {
cd "$srcdir/$_sourcedirectory/"
dune build -p "$_projectname" --verbose
}
-# re-enable when ocaml-ppx_jane (dep of ocampl-cinaps) is updated
-# check() {
-# cd "$srcdir/$_sourcedirectory/"
-# dune runtest -p "$_projectname" --verbose
-# }
+check() {
+ cd "$srcdir/$_sourcedirectory/"
+ dune runtest -p "$_projectname" --verbose
+}
package() {
cd "$srcdir/$_sourcedirectory/"