summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-04-15 19:34:12 +0200
committerDaniel Peukert2020-04-15 19:34:12 +0200
commita708894050695978a6e9aefcc96cfec38a4415d9 (patch)
treec2d84f6bc4c4e16a52df35bf825958ce0c365248
parent3115ec9f9d01e37919b4a07facedeeac577ed42e (diff)
downloadaur-a708894050695978a6e9aefcc96cfec38a4415d9.tar.gz
Fixed circular dependency
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c19b3c00fa4..f6f54d81832e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ppxlib
pkgdesc = Base library and tools for ppx rewriters
pkgver = 0.13.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ocaml-ppx/ppxlib
arch = x86_64
arch = i686
@@ -10,8 +10,6 @@ pkgbase = ocaml-ppxlib
arch = armv7h
arch = aarch64
license = MIT
- checkdepends = ocaml-cinaps>=0.12.1
- checkdepends = ocaml-findlib
makedepends = dune
depends = ocaml>=4.04.1
depends = ocaml-base>=0.11.0
@@ -20,8 +18,8 @@ pkgbase = ocaml-ppxlib
depends = ocaml-ppx_derivers>=1.0.0
depends = ocaml-stdio>=0.11.0
options = !strip
- source = ocaml-ppxlib-0.13.0-1.tar.gz::https://github.com/ocaml-ppx/ppxlib/archive/0.13.0.tar.gz
- source = ocaml-ppxlib-0.13.0-1-fix-tests.diff::https://github.com/ocaml-ppx/ppxlib/pull/111.diff
+ source = ocaml-ppxlib-0.13.0-2.tar.gz::https://github.com/ocaml-ppx/ppxlib/archive/0.13.0.tar.gz
+ source = ocaml-ppxlib-0.13.0-2-fix-tests.diff::https://github.com/ocaml-ppx/ppxlib/pull/111.diff
sha256sums = 59fd9eaac23e6fd1c5b6183c37499ec3dbabee1f6c7ede4fb080e5f9b746f4e0
sha256sums = 891640f82db542e682d250547e1f39290b8a230b287fbcd0b22c2e43adaa6f64
diff --git a/PKGBUILD b/PKGBUILD
index ebbf77eb8f1f..887647725077 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,13 @@
_projectname='ppxlib'
pkgname="ocaml-$_projectname"
pkgver='0.13.0'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Base library and tools for ppx rewriters'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-ppx/$_projectname"
license=('MIT')
depends=('ocaml>=4.04.1' 'ocaml-base>=0.11.0' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-migrate-parsetree>=1.3.1' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-stdio>=0.11.0')
makedepends=('dune')
-checkdepends=('ocaml-cinaps>=0.12.1' 'ocaml-findlib')
options=('!strip')
source=(
"$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
@@ -32,10 +31,11 @@ build() {
dune build -p "$_projectname" --verbose
}
-check() {
- cd "$srcdir/$_sourcedirectory/"
- dune runtest -p "$_projectname" --verbose
-}
+# fails because of a circular dependency on this package by ppx_jane
+# check() {
+# cd "$srcdir/$_sourcedirectory/"
+# dune runtest -p "$_projectname" --verbose
+# }
package() {
cd "$srcdir/$_sourcedirectory/"