summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-04-18 13:18:59 +0200
committerDaniel Peukert2020-04-18 13:18:59 +0200
commitb0c8c9804fddf97a77f3d747affc51f9af3ebd09 (patch)
tree57ddfc16e3d66a1a6b00b294e05d4bdfd28590fc
parenta708894050695978a6e9aefcc96cfec38a4415d9 (diff)
downloadaur-b0c8c9804fddf97a77f3d747affc51f9af3ebd09.tar.gz
Removed unused patch from ocaml-ppxlib
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 3 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6f54d81832e..08eef54d70e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,8 +19,6 @@ pkgbase = ocaml-ppxlib
depends = ocaml-stdio>=0.11.0
options = !strip
source = ocaml-ppxlib-0.13.0-2.tar.gz::https://github.com/ocaml-ppx/ppxlib/archive/0.13.0.tar.gz
- source = ocaml-ppxlib-0.13.0-2-fix-tests.diff::https://github.com/ocaml-ppx/ppxlib/pull/111.diff
sha256sums = 59fd9eaac23e6fd1c5b6183c37499ec3dbabee1f6c7ede4fb080e5f9b746f4e0
- sha256sums = 891640f82db542e682d250547e1f39290b8a230b287fbcd0b22c2e43adaa6f64
pkgname = ocaml-ppxlib
diff --git a/PKGBUILD b/PKGBUILD
index 887647725077..2bf2ed0534a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,27 +11,18 @@ license=('MIT')
depends=('ocaml>=4.04.1' 'ocaml-base>=0.11.0' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-migrate-parsetree>=1.3.1' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-stdio>=0.11.0')
makedepends=('dune')
options=('!strip')
-source=(
- "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
- "$pkgname-$pkgver-$pkgrel-fix-tests.diff::$url/pull/111.diff"
-)
-sha256sums=('59fd9eaac23e6fd1c5b6183c37499ec3dbabee1f6c7ede4fb080e5f9b746f4e0'
- '891640f82db542e682d250547e1f39290b8a230b287fbcd0b22c2e43adaa6f64')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('59fd9eaac23e6fd1c5b6183c37499ec3dbabee1f6c7ede4fb080e5f9b746f4e0')
_sourcedirectory="$_projectname-$pkgver"
-prepare() {
- cd "$srcdir/$_sourcedirectory/"
- # https://github.com/ocaml-ppx/ppxlib/pull/111
- patch --forward -p1 < "../$pkgname-$pkgver-$pkgrel-fix-tests.diff"
-}
-
build() {
cd "$srcdir/$_sourcedirectory/"
dune build -p "$_projectname" --verbose
}
# fails because of a circular dependency on this package by ppx_jane
+# $pkgname-$pkgver-$pkgrel-fix-tests.diff::https://github.com/ocaml-ppx/ppxlib/pull/111
# check() {
# cd "$srcdir/$_sourcedirectory/"
# dune runtest -p "$_projectname" --verbose