summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2021-06-29 23:30:19 +0200
committerDaniel Peukert2021-06-29 23:30:19 +0200
commitb9e0d601149085acd7860c97487a422af4ac0b8c (patch)
tree8ec6f94015e89da3999aa3bcdedce5a8f606ee79
parentbbdd5e6c1a217b930c01dfddbc9ddfce602921f5 (diff)
downloadaur-b9e0d601149085acd7860c97487a422af4ac0b8c.tar.gz
Update ocaml-ppxlib to 0.22.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--ocaml-migrate-parsetree2.diff24
3 files changed, 28 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96a791e9d005..557aabbc5ece 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ocaml-ppxlib
pkgdesc = Standard library for ppx rewriters
- pkgver = 0.22.1
+ pkgver = 0.22.2
pkgrel = 1
url = https://github.com/ocaml-ppx/ppxlib
arch = x86_64
@@ -13,14 +13,14 @@ pkgbase = ocaml-ppxlib
makedepends = dune>=2.7.0
depends = ocaml>=4.04.1
depends = ocaml-compiler-libs-repackaged>=0.11.0
- depends = ocaml-migrate-parsetree2>=2.1.0
+ depends = ocaml-migrate-parsetree2>=2.2.0
depends = ocaml-ppx_derivers>=1.0.0
depends = ocaml-sexplib0
depends = ocaml-stdlib-shims
options = !strip
- source = ocaml-ppxlib-0.22.1-1.tar.gz::https://github.com/ocaml-ppx/ppxlib/archive/0.22.1.tar.gz
+ source = ocaml-ppxlib-0.22.2-1.tar.gz::https://github.com/ocaml-ppx/ppxlib/archive/0.22.2.tar.gz
source = ocaml-migrate-parsetree2.diff
- sha256sums = 2768bd8fd3b914ccaa712f712889efbb54e835b7984a426505c9bbd82cc6a021
- sha256sums = cf977ee409e297548eede7ab7fd682e41cd22cb594d26c8c481e9198173f9aca
+ sha256sums = 8bdb42e3fb17240ad5578da621c37c73bbc02507ecc27d193d1b4cf11a4ea05d
+ sha256sums = 7c9586671c3b39e49b7f38c7c7765887cba1a9417484b3c1112677997da35d12
pkgname = ocaml-ppxlib
diff --git a/PKGBUILD b/PKGBUILD
index 713ca5b69c1a..42765757fe5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppxlib'
pkgname="ocaml-$_projectname"
-pkgver='0.22.1'
+pkgver='0.22.2'
pkgrel='1'
pkgdesc='Standard library for ppx rewriters'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-ppx/$_projectname"
license=('MIT')
-depends=('ocaml>=4.04.1' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-migrate-parsetree2>=2.1.0' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-sexplib0' 'ocaml-stdlib-shims')
+depends=('ocaml>=4.04.1' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-migrate-parsetree2>=2.2.0' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-sexplib0' 'ocaml-stdlib-shims')
makedepends=('dune>=2.7.0')
options=('!strip')
source=(
"$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
'ocaml-migrate-parsetree2.diff'
)
-sha256sums=('2768bd8fd3b914ccaa712f712889efbb54e835b7984a426505c9bbd82cc6a021'
- 'cf977ee409e297548eede7ab7fd682e41cd22cb594d26c8c481e9198173f9aca')
+sha256sums=('8bdb42e3fb17240ad5578da621c37c73bbc02507ecc27d193d1b4cf11a4ea05d'
+ '7c9586671c3b39e49b7f38c7c7765887cba1a9417484b3c1112677997da35d12')
_sourcedirectory="$_projectname-$pkgver"
diff --git a/ocaml-migrate-parsetree2.diff b/ocaml-migrate-parsetree2.diff
index 89f66b89493f..b75f00f1b6e3 100644
--- a/ocaml-migrate-parsetree2.diff
+++ b/ocaml-migrate-parsetree2.diff
@@ -38,7 +38,7 @@ index af9023b..d67d75d 100644
(:standard -open Ocaml_shadow -safe-string)
-w
diff --git a/ast/versions.ml b/ast/versions.ml
-index 4898cf2..5971797 100644
+index 4e22a1d..1f664b8 100644
--- a/ast/versions.ml
+++ b/ast/versions.ml
@@ -399,8 +399,8 @@ end
@@ -52,7 +52,7 @@ index 4898cf2..5971797 100644
printf " let version = %d\n" n;
printf " let string_version = %S\n" version;
printf "end\n";
-@@ -409,78 +409,78 @@ end
+@@ -409,85 +409,85 @@ end
)
*)
module OCaml_402 = struct
@@ -153,7 +153,16 @@ index 4898cf2..5971797 100644
let version = 412
let string_version = "4.12"
end
-@@ -506,29 +506,29 @@ let all_versions : (module OCaml_version) list = [
+ let ocaml_412 : OCaml_412.types ocaml_version = (module OCaml_412)
+ module OCaml_413 = struct
+- module Ast = Migrate_parsetree.Ast_413
+- include Make_witness(Migrate_parsetree.Ast_413)
++ module Ast = Migrate_parsetree2.Ast_413
++ include Make_witness(Migrate_parsetree2.Ast_413)
+ let version = 413
+ let string_version = "4.13"
+ end
+@@ -514,31 +514,31 @@ let all_versions : (module OCaml_version) list = [
(*$foreach_version_pair (fun a b ->
printf "include Register_migration(OCaml_%d)(OCaml_%d)\n" a b;
@@ -191,14 +200,17 @@ index 4898cf2..5971797 100644
include Register_migration(OCaml_411)(OCaml_412)
- (Migrate_parsetree.Migrate_411_412)(Migrate_parsetree.Migrate_412_411)
+ (Migrate_parsetree2.Migrate_411_412)(Migrate_parsetree2.Migrate_412_411)
+ include Register_migration(OCaml_412)(OCaml_413)
+- (Migrate_parsetree.Migrate_412_413)(Migrate_parsetree.Migrate_413_412)
++ (Migrate_parsetree2.Migrate_412_413)(Migrate_parsetree2.Migrate_413_412)
(*$*)
module OCaml_current = OCaml_OCAML_VERSION
diff --git a/ast/versions.mli b/ast/versions.mli
-index 5e01a6a..dca29dc 100644
+index df7576d..7b82093 100644
--- a/ast/versions.mli
+++ b/ast/versions.mli
-@@ -112,20 +112,20 @@ end
+@@ -112,21 +112,21 @@ end
(** {1 Concrete frontend instances} *)
(*$foreach_version (fun n _ ->
@@ -217,6 +229,7 @@ index 5e01a6a..dca29dc 100644
-module OCaml_410 : OCaml_version with module Ast = Migrate_parsetree.Ast_410
-module OCaml_411 : OCaml_version with module Ast = Migrate_parsetree.Ast_411
-module OCaml_412 : OCaml_version with module Ast = Migrate_parsetree.Ast_412
+-module OCaml_413 : OCaml_version with module Ast = Migrate_parsetree.Ast_413
+module OCaml_402 : OCaml_version with module Ast = Migrate_parsetree2.Ast_402
+module OCaml_403 : OCaml_version with module Ast = Migrate_parsetree2.Ast_403
+module OCaml_404 : OCaml_version with module Ast = Migrate_parsetree2.Ast_404
@@ -228,6 +241,7 @@ index 5e01a6a..dca29dc 100644
+module OCaml_410 : OCaml_version with module Ast = Migrate_parsetree2.Ast_410
+module OCaml_411 : OCaml_version with module Ast = Migrate_parsetree2.Ast_411
+module OCaml_412 : OCaml_version with module Ast = Migrate_parsetree2.Ast_412
++module OCaml_413 : OCaml_version with module Ast = Migrate_parsetree2.Ast_413
(*$*)
(* An alias to the current compiler version *)