summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2021-02-18 17:50:24 +0100
committerDaniel Peukert2021-02-18 17:50:24 +0100
commitf78cc3b710ef0af07dd73f07118ba2aa57e40556 (patch)
tree5d58dcb26f9db699a8d0084392153f3bfe03beb2
parentc38ae54194c3d85247bb78f23cca89cfb78118bc (diff)
downloadaur-f78cc3b710ef0af07dd73f07118ba2aa57e40556.tar.gz
Update OMP2 patch for ocaml-ppxlib
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--ocaml-migrate-parsetree2.diff40
3 files changed, 25 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ea31b2df967..73b07de69d32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ppxlib
pkgdesc = Standard library for ppx rewriters
pkgver = 0.22.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ocaml-ppx/ppxlib
arch = x86_64
arch = i686
@@ -18,9 +18,9 @@ pkgbase = ocaml-ppxlib
depends = ocaml-sexplib0
depends = ocaml-stdlib-shims
options = !strip
- source = ocaml-ppxlib-0.22.0-1.tar.gz::https://github.com/ocaml-ppx/ppxlib/archive/0.22.0.tar.gz
+ source = ocaml-ppxlib-0.22.0-2.tar.gz::https://github.com/ocaml-ppx/ppxlib/archive/0.22.0.tar.gz
source = ocaml-migrate-parsetree2.diff
sha256sums = 826f859c760901d437dc63bc490422f49befac8c3d2a620dc547a7d5c5147b20
- sha256sums = cf9c23418e0a6b166b147462278c594e5e48ffd933a3703daf6aa38bc77f666a
+ sha256sums = cf977ee409e297548eede7ab7fd682e41cd22cb594d26c8c481e9198173f9aca
pkgname = ocaml-ppxlib
diff --git a/PKGBUILD b/PKGBUILD
index ca1a06f13715..4d86af158307 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_projectname='ppxlib'
pkgname="ocaml-$_projectname"
pkgver='0.22.0'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Standard library for ppx rewriters'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-ppx/$_projectname"
@@ -16,7 +16,7 @@ source=(
'ocaml-migrate-parsetree2.diff'
)
sha256sums=('826f859c760901d437dc63bc490422f49befac8c3d2a620dc547a7d5c5147b20'
- 'cf9c23418e0a6b166b147462278c594e5e48ffd933a3703daf6aa38bc77f666a')
+ 'cf977ee409e297548eede7ab7fd682e41cd22cb594d26c8c481e9198173f9aca')
_sourcedirectory="$_projectname-$pkgver"
diff --git a/ocaml-migrate-parsetree2.diff b/ocaml-migrate-parsetree2.diff
index 62207003a133..89f66b89493f 100644
--- a/ocaml-migrate-parsetree2.diff
+++ b/ocaml-migrate-parsetree2.diff
@@ -1,44 +1,44 @@
diff --git a/ast/ast_helper_lite.ml b/ast/ast_helper_lite.ml
-index 11c6bbf..5f012e9 100644
+index 38ee444..9eb57b4 100644
--- a/ast/ast_helper_lite.ml
+++ b/ast/ast_helper_lite.ml
@@ -20,7 +20,7 @@ open Ocaml_common
module Location = Location
module Longident = Longident
--open Migrate_parsetree.Ast_411
-+open Migrate_parsetree2.Ast_411
+-open Migrate_parsetree.Ast_412
++open Migrate_parsetree2.Ast_412
[@@@warning "-9"]
open Asttypes
diff --git a/ast/ast_helper_lite.mli b/ast/ast_helper_lite.mli
-index 99bdeef..d2678f5 100644
+index 85c1e87..05f3580 100644
--- a/ast/ast_helper_lite.mli
+++ b/ast/ast_helper_lite.mli
@@ -16,7 +16,7 @@
- (** Copy of Ast_helper from OCaml 4.10 with docstring related stuff removed *)
+ (** Copy of Ast_helper from OCaml 4.12 with docstring related stuff removed *)
open Ocaml_common
--open Migrate_parsetree.Ast_411
-+open Migrate_parsetree2.Ast_411
+-open Migrate_parsetree.Ast_412
++open Migrate_parsetree2.Ast_412
open Asttypes
open Parsetree
diff --git a/ast/dune b/ast/dune
-index eefc483..4faecd5 100644
+index af9023b..d67d75d 100644
--- a/ast/dune
+++ b/ast/dune
-@@ -9,7 +9,7 @@
- ocaml-compiler-libs.shadow
- ocaml-compiler-libs.common
- compiler-libs.common
-- ocaml-migrate-parsetree
-+ ocaml-migrate-parsetree2
- stdlib-shims)
- (flags (:standard -open Ocaml_shadow -safe-string) -w -9-27-32)
- (preprocess
+@@ -6,7 +6,7 @@
+ (name ppxlib_ast)
+ (public_name ppxlib.ast)
+ (libraries ocaml-compiler-libs.shadow ocaml-compiler-libs.common
+- compiler-libs.common ocaml-migrate-parsetree stdlib-shims)
++ compiler-libs.common ocaml-migrate-parsetree2 stdlib-shims)
+ (flags
+ (:standard -open Ocaml_shadow -safe-string)
+ -w
diff --git a/ast/versions.ml b/ast/versions.ml
-index c1ef2e2..e4fd9bc 100644
+index 4898cf2..5971797 100644
--- a/ast/versions.ml
+++ b/ast/versions.ml
@@ -399,8 +399,8 @@ end
@@ -153,7 +153,7 @@ index c1ef2e2..e4fd9bc 100644
let version = 412
let string_version = "4.12"
end
-@@ -489,29 +489,29 @@ let ocaml_412 : OCaml_412.types ocaml_version = (module OCaml_412)
+@@ -506,29 +506,29 @@ let all_versions : (module OCaml_version) list = [
(*$foreach_version_pair (fun a b ->
printf "include Register_migration(OCaml_%d)(OCaml_%d)\n" a b;
@@ -195,7 +195,7 @@ index c1ef2e2..e4fd9bc 100644
module OCaml_current = OCaml_OCAML_VERSION
diff --git a/ast/versions.mli b/ast/versions.mli
-index fbc8516..44808d0 100644
+index 5e01a6a..dca29dc 100644
--- a/ast/versions.mli
+++ b/ast/versions.mli
@@ -112,20 +112,20 @@ end