summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-10-23 12:31:55 +0200
committerDaniel Peukert2020-10-23 12:31:55 +0200
commitfa3e3522b6c6fd5a1e78eafba7d94e26f2036d67 (patch)
treed066000de55465dffe53e330fabf4515b73979c4
parent4217a8daeb0b989c5342a400620bbdc8296d761c (diff)
downloadaur-fa3e3522b6c6fd5a1e78eafba7d94e26f2036d67.tar.gz
Updated ocaml-ppxlib to 0.19.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--ocaml-migrate-parsetree2.diff24
3 files changed, 28 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a88ca00f401..1d5d41b562f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ocaml-ppxlib
pkgdesc = Standard library for ppx rewriters
- pkgver = 0.18.0
+ pkgver = 0.19.0
pkgrel = 1
url = https://github.com/ocaml-ppx/ppxlib
arch = x86_64
@@ -13,14 +13,14 @@ pkgbase = ocaml-ppxlib
makedepends = dune>=1.11.0
depends = ocaml>=4.04.1
depends = ocaml-compiler-libs-repackaged>=0.11.0
- depends = ocaml-migrate-parsetree2
+ depends = ocaml-migrate-parsetree2>=2.1.0
depends = ocaml-ppx_derivers>=1.0.0
depends = ocaml-sexplib0
depends = ocaml-stdlib-shims
options = !strip
- source = ocaml-ppxlib-0.18.0-1.tar.gz::https://github.com/ocaml-ppx/ppxlib/archive/0.18.0.tar.gz
+ source = ocaml-ppxlib-0.19.0-1.tar.gz::https://github.com/ocaml-ppx/ppxlib/archive/0.19.0.tar.gz
source = ocaml-migrate-parsetree2.diff
- sha256sums = 64a9bfc78fa27b55a164ec5f37f74ca7843d0b94dd3f97d7bf2f7991cef470e4
- sha256sums = bf1afe67407932df77f7cd786218e4fba45658586ec285e8988789e883281dac
+ sha256sums = 7a58d4f8decd0b3b49267f67b58638295d9144a859f36f37e5607ab73eb1af71
+ sha256sums = cf9c23418e0a6b166b147462278c594e5e48ffd933a3703daf6aa38bc77f666a
pkgname = ocaml-ppxlib
diff --git a/PKGBUILD b/PKGBUILD
index 7968d7c7d465..7fbf7db6dd19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppxlib'
pkgname="ocaml-$_projectname"
-pkgver='0.18.0'
+pkgver='0.19.0'
pkgrel='1'
pkgdesc='Standard library for ppx rewriters'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-ppx/$_projectname"
license=('MIT')
-depends=('ocaml>=4.04.1' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-migrate-parsetree2' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-sexplib0' 'ocaml-stdlib-shims')
+depends=('ocaml>=4.04.1' 'ocaml-compiler-libs-repackaged>=0.11.0' 'ocaml-migrate-parsetree2>=2.1.0' 'ocaml-ppx_derivers>=1.0.0' 'ocaml-sexplib0' 'ocaml-stdlib-shims')
makedepends=('dune>=1.11.0')
options=('!strip')
source=(
"$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
'ocaml-migrate-parsetree2.diff'
)
-sha256sums=('64a9bfc78fa27b55a164ec5f37f74ca7843d0b94dd3f97d7bf2f7991cef470e4'
- 'bf1afe67407932df77f7cd786218e4fba45658586ec285e8988789e883281dac')
+sha256sums=('7a58d4f8decd0b3b49267f67b58638295d9144a859f36f37e5607ab73eb1af71'
+ 'cf9c23418e0a6b166b147462278c594e5e48ffd933a3703daf6aa38bc77f666a')
_sourcedirectory="$_projectname-$pkgver"
diff --git a/ocaml-migrate-parsetree2.diff b/ocaml-migrate-parsetree2.diff
index 7c0365d00dbc..62207003a133 100644
--- a/ocaml-migrate-parsetree2.diff
+++ b/ocaml-migrate-parsetree2.diff
@@ -38,7 +38,7 @@ index eefc483..4faecd5 100644
(flags (:standard -open Ocaml_shadow -safe-string) -w -9-27-32)
(preprocess
diff --git a/ast/versions.ml b/ast/versions.ml
-index dbad548..2d08a0e 100644
+index c1ef2e2..e4fd9bc 100644
--- a/ast/versions.ml
+++ b/ast/versions.ml
@@ -399,8 +399,8 @@ end
@@ -52,7 +52,7 @@ index dbad548..2d08a0e 100644
printf " let version = %d\n" n;
printf " let string_version = %S\n" version;
printf "end\n";
-@@ -409,71 +409,71 @@ end
+@@ -409,78 +409,78 @@ end
)
*)
module OCaml_402 = struct
@@ -144,7 +144,16 @@ index dbad548..2d08a0e 100644
let version = 411
let string_version = "4.11"
end
-@@ -482,27 +482,27 @@ let ocaml_411 : OCaml_411.types ocaml_version = (module OCaml_411)
+ let ocaml_411 : OCaml_411.types ocaml_version = (module OCaml_411)
+ module OCaml_412 = struct
+- module Ast = Migrate_parsetree.Ast_412
+- include Make_witness(Migrate_parsetree.Ast_412)
++ module Ast = Migrate_parsetree2.Ast_412
++ include Make_witness(Migrate_parsetree2.Ast_412)
+ let version = 412
+ let string_version = "4.12"
+ end
+@@ -489,29 +489,29 @@ let ocaml_412 : OCaml_412.types ocaml_version = (module OCaml_412)
(*$foreach_version_pair (fun a b ->
printf "include Register_migration(OCaml_%d)(OCaml_%d)\n" a b;
@@ -179,14 +188,17 @@ index dbad548..2d08a0e 100644
include Register_migration(OCaml_410)(OCaml_411)
- (Migrate_parsetree.Migrate_410_411)(Migrate_parsetree.Migrate_411_410)
+ (Migrate_parsetree2.Migrate_410_411)(Migrate_parsetree2.Migrate_411_410)
+ include Register_migration(OCaml_411)(OCaml_412)
+- (Migrate_parsetree.Migrate_411_412)(Migrate_parsetree.Migrate_412_411)
++ (Migrate_parsetree2.Migrate_411_412)(Migrate_parsetree2.Migrate_412_411)
(*$*)
module OCaml_current = OCaml_OCAML_VERSION
diff --git a/ast/versions.mli b/ast/versions.mli
-index f36bef5..bc4fee8 100644
+index fbc8516..44808d0 100644
--- a/ast/versions.mli
+++ b/ast/versions.mli
-@@ -112,19 +112,19 @@ end
+@@ -112,20 +112,20 @@ end
(** {1 Concrete frontend instances} *)
(*$foreach_version (fun n _ ->
@@ -204,6 +216,7 @@ index f36bef5..bc4fee8 100644
-module OCaml_409 : OCaml_version with module Ast = Migrate_parsetree.Ast_409
-module OCaml_410 : OCaml_version with module Ast = Migrate_parsetree.Ast_410
-module OCaml_411 : OCaml_version with module Ast = Migrate_parsetree.Ast_411
+-module OCaml_412 : OCaml_version with module Ast = Migrate_parsetree.Ast_412
+module OCaml_402 : OCaml_version with module Ast = Migrate_parsetree2.Ast_402
+module OCaml_403 : OCaml_version with module Ast = Migrate_parsetree2.Ast_403
+module OCaml_404 : OCaml_version with module Ast = Migrate_parsetree2.Ast_404
@@ -214,6 +227,7 @@ index f36bef5..bc4fee8 100644
+module OCaml_409 : OCaml_version with module Ast = Migrate_parsetree2.Ast_409
+module OCaml_410 : OCaml_version with module Ast = Migrate_parsetree2.Ast_410
+module OCaml_411 : OCaml_version with module Ast = Migrate_parsetree2.Ast_411
++module OCaml_412 : OCaml_version with module Ast = Migrate_parsetree2.Ast_412
(*$*)
(* An alias to the current compiler version *)