summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-18 21:29:41 +0200
committerGoliathLabs2020-05-18 21:29:41 +0200
commit0b9af41428adfda4625af8bb57a4d6b96a9dab63 (patch)
tree351c19937e52a937598ce49039ad2bc0708ab37a
parent8ac4f0f449a3a3774b8ccf23fd549e7ca3b6f18d (diff)
downloadaur-ocaml-psmt2-frontend-git.tar.gz
Updated: PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD36
2 files changed, 18 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6d6781cdff4..94250dca5262 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = ocaml-psmt2-frontend-git
pkgdesc = A simple parser and type-checker for polomorphic extension of the SMT-LIB 2 language
- pkgver = 0.1
+ pkgver = r22.bb35b53
pkgrel = 1
- url = https://github.com/Coquera/psmt2-frontend
+ url = https://github.com/OCamlPro-Coquera/psmt2-frontend
arch = i686
arch = x86_64
license = Apache2
@@ -13,6 +13,8 @@ pkgbase = ocaml-psmt2-frontend-git
conflicts = ocaml-psmt2-frontend
options = !strip
options = staticlibs
+ source = git+https://github.com/OCamlPro-Coquera/psmt2-frontend.git
+ md5sums = SKIP
pkgname = ocaml-psmt2-frontend-git
diff --git a/PKGBUILD b/PKGBUILD
index 196ffe4ee515..70a1e58d6256 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,37 @@
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+
pkgname=ocaml-psmt2-frontend-git
-pkgver=0.1
+_pkgname=psmt2-frontend
+pkgver=r22.bb35b53
pkgrel=1
pkgdesc="A simple parser and type-checker for polomorphic extension of the SMT-LIB 2 language"
arch=('i686' 'x86_64')
-url="https://github.com/Coquera/psmt2-frontend"
+url="https://github.com/OCamlPro-Coquera/psmt2-frontend"
license=('Apache2')
depends=('ocaml')
makedepends=('ocaml' 'ocaml-menhir')
options=(!strip staticlibs)
provides=('ocaml-psmt2-frontend')
conflicts=('ocaml-psmt2-frontend')
+source=("git+https://github.com/OCamlPro-Coquera/psmt2-frontend.git")
+md5sums=('SKIP')
-# TODO: update from Coquera to mewpull when PR #4 is merged.
-_gitroot="https://github.com/Coquera/psmt2-frontend.git"
-_gitname="psmt2-frontend"
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
- cd "$srcdir"
-
- if [ -d "$srcdir/$_gitname" ]; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting make..."
-
-
- cp -rf "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
-
+ cd "$srcdir/$_pkgname"
autoconf
./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/$_gitname-build"
+ cd "$srcdir/$_pkgname"
mkdir -p "$pkgdir/usr/lib/ocaml/psmt2-frontend"
make DESTDIR="$pkgdir/usr" LIBDIR="$pkgdir/usr/lib/ocaml" install
}
+