summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2021-02-28 21:39:46 +0100
committerGianluca Boiano2021-02-28 21:39:46 +0100
commit782c02d9bc760ce551e4d9930394859dcb77c0d9 (patch)
treeff1176138ee5fcaf60c26e931612f49b8788790d
parentf41795e90f9860efea62cb449eedbc40efae4b49 (diff)
downloadaur-782c02d9bc760ce551e4d9930394859dcb77c0d9.tar.gz
ocaml-pulseaudio: 0.1.4
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b934fbc0c531..1db523ebec21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
-# Generated by mksrcinfo v8
-# Tue Jun 6 12:35:22 UTC 2017
pkgbase = ocaml-pulseaudio
pkgdesc = OCaml bindings for pulseaudio
- pkgver = 0.1.3
+ pkgver = 0.1.4
pkgrel = 1
url = https://github.com/savonet/ocaml-pulseaudio
arch = i686
arch = x86_64
license = LGPL2.1
makedepends = ocaml-findlib
+ makedepends = dune
depends = ocaml
depends = libpulse
options = !strip
- source = https://github.com/savonet/ocaml-pulseaudio/releases/download/0.1.3/ocaml-pulseaudio-0.1.3.tar.gz
- md5sums = bd04013ada1a6ed72e111e406befc709
+ source = https://github.com/savonet/ocaml-pulseaudio/archive/v0.1.4.tar.gz
+ md5sums = f73f732602cc3a70d418a307d32a87bd
pkgname = ocaml-pulseaudio
diff --git a/PKGBUILD b/PKGBUILD
index 75a2d097ef65..29742fdfc4a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Maintainer: robertfoster
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-pulseaudio
-pkgver=0.1.3
+pkgver=0.1.4
pkgrel=1
pkgdesc="OCaml bindings for pulseaudio"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-pulseaudio"
license=('LGPL2.1')
depends=('ocaml' 'libpulse')
-makedepends=('ocaml-findlib')
+makedepends=('ocaml-findlib' 'dune')
options=('!strip')
-source=("https://github.com/savonet/ocaml-pulseaudio/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('bd04013ada1a6ed72e111e406befc709')
+source=("${url}/archive/v${pkgver}.tar.gz")
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure
- make
+ dune build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
- make install
+ DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir "lib/ocaml"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}
+
+md5sums=('f73f732602cc3a70d418a307d32a87bd')