summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2018-06-28 18:18:05 +0200
committerJakob Gahde2018-06-28 18:18:05 +0200
commita0f21305565fc101ab7be9da4f9964a7eed3c031 (patch)
treefc8ab77f862ae2dbb29c3570507681c606eb1d1e
parentf218ea344c41477a13618c1d5b16d68be9897820 (diff)
downloadaur-a0f21305565fc101ab7be9da4f9964a7eed3c031.tar.gz
ocaml-re 1.7.3-1: New version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6bb828c0e220..02a167559e6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
# Generated by mksrcinfo v8
-# Tue Jun 6 12:36:22 UTC 2017
+# Thu Jun 28 16:17:53 UTC 2018
pkgbase = ocaml-re
pkgdesc = Pure OCaml regular expressions, with support for Perl and POSIX-style strings
- pkgver = 1.7.1
+ pkgver = 1.7.3
pkgrel = 1
url = https://github.com/ocaml/ocaml-re
arch = i686
arch = x86_64
- license = LGPL
- makedepends = ocamlbuild
- makedepends = ocaml-findlib
+ license = custom:LGPL2.1 with linking exception
+ makedepends = dune
depends = ocaml
options = !strip
- source = https://github.com/ocaml/ocaml-re/archive/1.7.1.tar.gz
- sha256sums = eb18382d63459b0a4065315ce6fef854bc99152aec2b557bb8a43e664e6679e8
+ source = https://github.com/ocaml/ocaml-re/archive/1.7.3.tar.gz
+ sha256sums = ea55060a1c556e3ceea4837af534567b09b7f15656281dadf8911aad6712f6c5
pkgname = ocaml-re
diff --git a/PKGBUILD b/PKGBUILD
index b8ac85c6f6f8..c83ec15dfa45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,30 @@
# Contributor: Taylor Venable <taylor@metasyntax.net>
pkgname=ocaml-re
-pkgver=1.7.1
+pkgver=1.7.3
pkgrel=1
pkgdesc="Pure OCaml regular expressions, with support for Perl and POSIX-style strings"
arch=('i686' 'x86_64')
url="https://github.com/ocaml/ocaml-re"
-license=('LGPL')
+license=('custom:LGPL2.1 with linking exception')
depends=('ocaml')
-makedepends=('ocamlbuild' 'ocaml-findlib')
+makedepends=('dune')
options=('!strip')
source=("https://github.com/ocaml/ocaml-re/archive/${pkgver}.tar.gz")
-sha256sums=('eb18382d63459b0a4065315ce6fef854bc99152aec2b557bb8a43e664e6679e8')
+sha256sums=('ea55060a1c556e3ceea4837af534567b09b7f15656281dadf8911aad6712f6c5')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix /usr
- make
+ jbuilder build
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}"
- make install
+ install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
+ jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}