summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:13:57 +0100
committerDaniel Peukert2024-01-28 00:13:57 +0100
commitddcef8c524ad5f78355a29bd6b3f005901e4e6dd (patch)
treeb01b06a067f64c81f6ca308285f7c63d58334de2
parent037fb84f0c25dbc7349a7621dd0974c18906a629 (diff)
downloadaur-ocaml-seq.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD20
3 files changed, 26 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 367dbc9f15fa..01a15b32fc19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,18 +5,16 @@ pkgbase = ocaml-seq
url = https://github.com/ocaml/opam-repository/tree/master/packages/seq/seq.base
arch = x86_64
arch = aarch64
- license = custom:CC0
+ license = CC0-1.0
makedepends = ocaml-findlib
makedepends = opam
depends = ocaml>=4.07.0
options = !strip
- source = ocaml-seq-base-8-opam::https://raw.githubusercontent.com/ocaml/opam-repository/cbb37092ecf7d4b3a5ff43a69aacbed19a4668e5/packages/seq/seq.base/opam
- source = ocaml-seq-base-8-META.seq::https://raw.githubusercontent.com/ocaml/opam-repository/cbb37092ecf7d4b3a5ff43a69aacbed19a4668e5/packages/seq/seq.base/files/META.seq
- source = ocaml-seq-base-8-seq.install::https://raw.githubusercontent.com/ocaml/opam-repository/cbb37092ecf7d4b3a5ff43a69aacbed19a4668e5/packages/seq/seq.base/files/seq.install
- source = ocaml-seq-base-8-COPYING::https://raw.githubusercontent.com/ocaml/opam-repository/cbb37092ecf7d4b3a5ff43a69aacbed19a4668e5/COPYING
+ source = ocaml-seq-base-opam::https://raw.githubusercontent.com/ocaml/opam-repository/cbb37092ecf7d4b3a5ff43a69aacbed19a4668e5/packages/seq/seq.base/opam
+ source = ocaml-seq-base-META.seq::https://raw.githubusercontent.com/ocaml/opam-repository/cbb37092ecf7d4b3a5ff43a69aacbed19a4668e5/packages/seq/seq.base/files/META.seq
+ source = ocaml-seq-base-seq.install::https://raw.githubusercontent.com/ocaml/opam-repository/cbb37092ecf7d4b3a5ff43a69aacbed19a4668e5/packages/seq/seq.base/files/seq.install
sha512sums = 3c233e2b8015ba229ccdd1906e47b2ffa793e22d4f4466011b7da4a6ec68d8f40cd6d9397aebde053722b2ea466c21d2dcb8dfcaf648c3d194b0009ce9a657a8
sha512sums = 1ad76cc25bf663d5d35e5ea9057bff11e7882d8ddc4367b6e38a761df0aa7a8fe76de2fe3b7080a575572dad26556261a05f6044906d7874df89e0157e35e623
sha512sums = 915b9de54aa9e0489876094ed83690c653c0436b4e0ef502ab28aa1133d10f3b30baa190306629ccc94b5bfa837bff4426ed32e627cfad8954d32e0d8536a6e0
- sha512sums = c14f8508ab81ed48588e1de314fd20e54eb0c08bdaaf4c50c2301a6ee2705d45e2d18db863a0f7a1cbb5e5ed11dbb9490378b3e64fb384b16f212c3f0e3d3c81
pkgname = ocaml-seq
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index de09ecb9bfe0..83c06cf8f160 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,34 +8,30 @@ pkgrel='8'
pkgdesc='Dummy backward-compatibility package for iterators'
arch=('x86_64' 'aarch64')
url="https://github.com/ocaml/opam-repository/tree/master/packages/$_projectname/$_projectname.$pkgver"
-license=('custom:CC0')
+license=('CC0-1.0')
depends=('ocaml>=4.07.0')
makedepends=('ocaml-findlib' 'opam')
options=('!strip')
source=(
- "$pkgname-$pkgver-$pkgrel-opam::https://raw.githubusercontent.com/ocaml/opam-repository/$_commit/packages/$_projectname/$_projectname.$pkgver/opam"
- "$pkgname-$pkgver-$pkgrel-META.seq::https://raw.githubusercontent.com/ocaml/opam-repository/$_commit/packages/$_projectname/$_projectname.$pkgver/files/META.seq"
- "$pkgname-$pkgver-$pkgrel-seq.install::https://raw.githubusercontent.com/ocaml/opam-repository/$_commit/packages/$_projectname/$_projectname.$pkgver/files/seq.install"
- "$pkgname-$pkgver-$pkgrel-COPYING::https://raw.githubusercontent.com/ocaml/opam-repository/$_commit/COPYING"
+ "$pkgname-$pkgver-opam::https://raw.githubusercontent.com/ocaml/opam-repository/$_commit/packages/$_projectname/$_projectname.$pkgver/opam"
+ "$pkgname-$pkgver-META.seq::https://raw.githubusercontent.com/ocaml/opam-repository/$_commit/packages/$_projectname/$_projectname.$pkgver/files/META.seq"
+ "$pkgname-$pkgver-seq.install::https://raw.githubusercontent.com/ocaml/opam-repository/$_commit/packages/$_projectname/$_projectname.$pkgver/files/seq.install"
)
sha512sums=('3c233e2b8015ba229ccdd1906e47b2ffa793e22d4f4466011b7da4a6ec68d8f40cd6d9397aebde053722b2ea466c21d2dcb8dfcaf648c3d194b0009ce9a657a8'
'1ad76cc25bf663d5d35e5ea9057bff11e7882d8ddc4367b6e38a761df0aa7a8fe76de2fe3b7080a575572dad26556261a05f6044906d7874df89e0157e35e623'
- '915b9de54aa9e0489876094ed83690c653c0436b4e0ef502ab28aa1133d10f3b30baa190306629ccc94b5bfa837bff4426ed32e627cfad8954d32e0d8536a6e0'
- 'c14f8508ab81ed48588e1de314fd20e54eb0c08bdaaf4c50c2301a6ee2705d45e2d18db863a0f7a1cbb5e5ed11dbb9490378b3e64fb384b16f212c3f0e3d3c81')
+ '915b9de54aa9e0489876094ed83690c653c0436b4e0ef502ab28aa1133d10f3b30baa190306629ccc94b5bfa837bff4426ed32e627cfad8954d32e0d8536a6e0')
_sourcedirectory="$_projectname-$pkgver"
prepare() {
cd "$srcdir/"
mkdir -p "$srcdir/$_sourcedirectory/files/"
- mv "$pkgname-$pkgver-$pkgrel-opam" "$srcdir/$_sourcedirectory/opam"
- mv "$pkgname-$pkgver-$pkgrel-COPYING" "$srcdir/$_sourcedirectory/COPYING"
- mv "$pkgname-$pkgver-$pkgrel-META.seq" "$srcdir/$_sourcedirectory/files/META.seq"
- mv "$pkgname-$pkgver-$pkgrel-seq.install" "$srcdir/$_sourcedirectory/files/seq.install"
+ mv "$pkgname-$pkgver-opam" "$srcdir/$_sourcedirectory/opam"
+ mv "$pkgname-$pkgver-META.seq" "$srcdir/$_sourcedirectory/files/META.seq"
+ mv "$pkgname-$pkgver-seq.install" "$srcdir/$_sourcedirectory/files/seq.install"
}
package() {
cd "$srcdir/$_sourcedirectory/files/"
opam-installer --libdir="$pkgdir$(ocamlfind -printconf destdir)"
- install -Dm644 '../COPYING' "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}