summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-03-15 00:52:15 +0100
committerDaniel Peukert2020-03-15 00:52:15 +0100
commit0274b8749824d488962e6222bc730e46e17138e9 (patch)
tree39855ff12caa36086d21d244a7cdd72c685ae52b
parentfcf1809c150c3405201f98a7949c7dc4d85bbcef (diff)
downloadaur-0274b8749824d488962e6222bc730e46e17138e9.tar.gz
Added ocaml-lwt and dependencies
-rw-r--r--.SRCINFO26
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD53
4 files changed, 77 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a76af4902e6..7838e4905f12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,26 @@
pkgbase = ocaml-seq
pkgdesc = Dummy backward-compatibility package for iterators
pkgver = base
- pkgrel = 1
- url = https://github.com/ocaml/opam-repository
- arch = any
+ pkgrel = 2
+ url = https://github.com/ocaml/opam-repository/tree/master/packages/seq/seq.base
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = custom:CC0
- makedepends = git
makedepends = ocaml-findlib
makedepends = opam
- depends = ocaml
- source = git+https://github.com/ocaml/opam-repository.git
- sha512sums = SKIP
+ depends = ocaml>=4.07.0
+ options = !strip
+ source = ocaml-seq-base-2-opam::https://raw.githubusercontent.com/ocaml/opam-repository/cbb37092ecf7d4b3a5ff43a69aacbed19a4668e5/packages/seq/seq.base/opam
+ source = ocaml-seq-base-2-META.seq::https://raw.githubusercontent.com/ocaml/opam-repository/cbb37092ecf7d4b3a5ff43a69aacbed19a4668e5/packages/seq/seq.base/files/META.seq
+ source = ocaml-seq-base-2-seq.install::https://raw.githubusercontent.com/ocaml/opam-repository/cbb37092ecf7d4b3a5ff43a69aacbed19a4668e5/packages/seq/seq.base/files/seq.install
+ source = ocaml-seq-base-2-COPYING::https://raw.githubusercontent.com/ocaml/opam-repository/cbb37092ecf7d4b3a5ff43a69aacbed19a4668e5/COPYING
+ sha256sums = 4524608ea1de87fe2058d7eb39bd82cb001095bea65865254ec50fefad399d5c
+ sha256sums = e95062b4d0519ef8335c02f7d0f1952d11b814c7ab7e6d566a206116162fa2be
+ sha256sums = fff926c2c4d5a82b6c94c60c4c35eb06e3d39975893ebe6b1f0e6557cbe34904
+ sha256sums = 6d489af6292662d9e36d34ce49423784984a5f6e41d7b58f49b01264df59fa03
pkgname = ocaml-seq
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index 19ec44374b5f..93636412f2ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,41 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
-
-pkgname=ocaml-seq
-pkgver=base
-pkgrel=1
-pkgdesc="Dummy backward-compatibility package for iterators"
-arch=('any')
-url="https://github.com/ocaml/opam-repository"
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
+_projectname='seq'
+pkgname="ocaml-$_projectname"
+pkgver='base'
+_commit='cbb37092ecf7d4b3a5ff43a69aacbed19a4668e5'
+pkgrel='2'
+pkgdesc='Dummy backward-compatibility package for iterators'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/ocaml/opam-repository/tree/master/packages/$_projectname/$_projectname.$pkgver"
license=('custom:CC0')
-depends=('ocaml')
-makedepends=('git' 'ocaml-findlib' 'opam')
-source=("git+https://github.com/ocaml/opam-repository.git")
-sha512sums=('SKIP')
+depends=('ocaml>=4.07.0')
+makedepends=('ocaml-findlib' 'opam')
+options=('!strip')
+source=(
+ "$pkgname-$pkgver-$pkgrel-opam::https://raw.githubusercontent.com/ocaml/opam-repository/$_commit/packages/$_projectname/$_projectname.$pkgver/opam"
+ "$pkgname-$pkgver-$pkgrel-META.seq::https://raw.githubusercontent.com/ocaml/opam-repository/$_commit/packages/$_projectname/$_projectname.$pkgver/files/META.seq"
+ "$pkgname-$pkgver-$pkgrel-seq.install::https://raw.githubusercontent.com/ocaml/opam-repository/$_commit/packages/$_projectname/$_projectname.$pkgver/files/seq.install"
+ "$pkgname-$pkgver-$pkgrel-COPYING::https://raw.githubusercontent.com/ocaml/opam-repository/$_commit/COPYING"
+)
+sha256sums=('4524608ea1de87fe2058d7eb39bd82cb001095bea65865254ec50fefad399d5c'
+ 'e95062b4d0519ef8335c02f7d0f1952d11b814c7ab7e6d566a206116162fa2be'
+ 'fff926c2c4d5a82b6c94c60c4c35eb06e3d39975893ebe6b1f0e6557cbe34904'
+ '6d489af6292662d9e36d34ce49423784984a5f6e41d7b58f49b01264df59fa03')
-package() {
- cd "${srcdir}/opam-repository/packages/seq/seq.${pkgver}/files"
+_sourcedirectory="$_projectname-$pkgver"
- opam-installer --libdir="${pkgdir}$(ocamlfind -printconf destdir)"
- install -Dm644 "${srcdir}/opam-repository/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+prepare() {
+ cd "$srcdir/"
+ mkdir -p "$srcdir/$_sourcedirectory/files/"
+ mv "$pkgname-$pkgver-$pkgrel-opam" "$srcdir/$_sourcedirectory/opam"
+ mv "$pkgname-$pkgver-$pkgrel-COPYING" "$srcdir/$_sourcedirectory/COPYING"
+ mv "$pkgname-$pkgver-$pkgrel-META.seq" "$srcdir/$_sourcedirectory/files/META.seq"
+ mv "$pkgname-$pkgver-$pkgrel-seq.install" "$srcdir/$_sourcedirectory/files/seq.install"
+}
+
+package() {
+ cd "$srcdir/$_sourcedirectory/files"
+ opam-installer --libdir="$pkgdir$(ocamlfind -printconf destdir)"
+ install -Dm644 '../COPYING' "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}