summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2018-10-06 18:18:01 +0200
committerJakob Gahde2018-10-06 18:18:01 +0200
commit42f9ca3019523cff97d9e635648989bcfa27225a (patch)
treebdb56bf521d93608e4f26bf0529f80a219dba08b
downloadaur-42f9ca3019523cff97d9e635648989bcfa27225a.tar.gz
ocaml-seq base-1: New package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5e788314481
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ocaml-seq
+ pkgdesc = Dummy backward-compatibility package for iterators
+ pkgver = base
+ pkgrel = 1
+ url = https://github.com/ocaml/opam-repository
+ arch = any
+ license = unknown
+ makedepends = git
+ makedepends = ocaml-findlib
+ makedepends = opam
+ depends = ocaml
+ source = git+https://github.com/ocaml/opam-repository.git
+ sha512sums = SKIP
+
+pkgname = ocaml-seq
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0dedda7860a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-seq
+pkgver=base
+pkgrel=1
+pkgdesc="Dummy backward-compatibility package for iterators"
+arch=('any')
+url="https://github.com/ocaml/opam-repository"
+license=('unknown')
+depends=('ocaml')
+makedepends=('git' 'ocaml-findlib' 'opam')
+source=("git+https://github.com/ocaml/opam-repository.git")
+sha512sums=('SKIP')
+
+package() {
+ cd "${srcdir}/opam-repository/packages/seq/seq.${pkgver}/files"
+
+ opam-installer --libdir="${pkgdir}$(ocamlfind -printconf destdir)"
+}