summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:14:03 +0100
committerDaniel Peukert2024-01-28 00:14:03 +0100
commitd8b5a690dcbfe2f2c9012e142629dd2c821909eb (patch)
tree4100f300410f945593b98f2d211e386e282c51ce
parent3b3b723b893e6fff723b072329036ebc05d290f4 (diff)
downloadaur-ocaml-sexplib.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD8
3 files changed, 21 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c43ee5c62c5d..af0190c4b34e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,13 +7,14 @@ pkgbase = ocaml-sexplib
arch = x86_64
arch = aarch64
license = MIT
+ license = BSD-3-Clause
makedepends = dune>=2.0.0
depends = ocaml>=4.14.0
depends = ocaml-num
depends = ocaml-parsexp>=0.16.0
depends = ocaml-sexplib0>=0.16.0
options = !strip
- source = ocaml-sexplib-1:0.16.0-1.tar.gz::https://github.com/janestreet/sexplib/archive/v0.16.0.tar.gz
+ source = ocaml-sexplib-0.16.0.tar.gz::https://github.com/janestreet/sexplib/archive/v0.16.0.tar.gz
sha512sums = f924d92ddf11f12be51073a3dfca45486d90b05533f29804518ee86b93386b8ff8d7e692c71d77b11347b78e9f6f6dcf7d79b71540efe54b013fa09b3bab414a
pkgname = ocaml-sexplib
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 7cdece6d1fc4..ca8a5900d47e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@ epoch='1'
pkgdesc='Library for serializing OCaml values to and from S-expressions'
arch=('x86_64' 'aarch64')
url="https://github.com/janestreet/$_projectname"
-license=('MIT')
+license=('MIT' 'BSD-3-Clause')
depends=('ocaml>=4.14.0' 'ocaml-num' 'ocaml-parsexp>=0.16.0' 'ocaml-sexplib0>=0.16.0')
makedepends=('dune>=2.0.0')
options=('!strip')
-source=("$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha512sums=('f924d92ddf11f12be51073a3dfca45486d90b05533f29804518ee86b93386b8ff8d7e692c71d77b11347b78e9f6f6dcf7d79b71540efe54b013fa09b3bab414a')
_sourcedirectory="$_projectname-$pkgver"
@@ -30,7 +30,9 @@ package() {
done
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- for _license in 'COPYRIGHT.txt' 'LICENSE.md' 'LICENSE-Tywith.txt' 'THIRD-PARTY.txt'; do
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/MIT"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE-Tywith.txt" "$pkgdir/usr/share/licenses/$pkgname/BSD-3-Clause"
+ for _license in 'COPYRIGHT.txt' 'THIRD-PARTY.txt'; do
ln -sf "/usr/share/doc/$pkgname/$_license" "$pkgdir/usr/share/licenses/$pkgname/$_license"
done
}