summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-05-14 13:34:12 +0200
committerJakob Gahde2019-05-14 13:34:12 +0200
commit7298d794682d85c6823416e0bf7bb534c8ff16bf (patch)
treeec94e7d68a063b4905ac8b6c74040acb652e6169
parent103dd74257638014d6e7a0db41f9194781ff08bb (diff)
downloadaur-7298d794682d85c6823416e0bf7bb534c8ff16bf.tar.gz
ocaml-sexplib0 0.12.0-1: New version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c2aa42ce736..995582a43109 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Jun 27 19:38:24 UTC 2018
pkgbase = ocaml-sexplib0
pkgdesc = Library containing the definition of S-expressions and some base converters
- pkgver = 0.11.0
+ pkgver = 0.12.0
pkgrel = 1
url = https://github.com/janestreet/sexplib0
arch = x86_64
@@ -10,8 +8,8 @@ pkgbase = ocaml-sexplib0
makedepends = dune
depends = ocaml
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/sexplib0-v0.11.0.tar.gz
- md5sums = 1c14ba30b471e49f1b23fea5ff99ea6b
+ source = https://ocaml.janestreet.com/ocaml-core/v0.12/files/sexplib0-v0.12.0.tar.gz
+ sha512sums = 104f8526a147cfa6ecf168c8ee10a78ad3133c0a8a3714dc9dffd6358152752b337262b857c89170e07071ae669724da6f5556304c5abb3e9ce505ec700b7ad8
pkgname = ocaml-sexplib0
diff --git a/PKGBUILD b/PKGBUILD
index 1222cf283cfe..83a4a9cc9116 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-sexplib0
-pkgver=0.11.0
+pkgver=0.12.0
pkgrel=1
pkgdesc="Library containing the definition of S-expressions and some base converters"
arch=('x86_64')
@@ -11,12 +11,12 @@ depends=('ocaml')
makedepends=('dune')
options=('!strip')
source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/sexplib0-v${pkgver}.tar.gz")
-md5sums=('1c14ba30b471e49f1b23fea5ff99ea6b')
+sha512sums=('104f8526a147cfa6ecf168c8ee10a78ad3133c0a8a3714dc9dffd6358152752b337262b857c89170e07071ae669724da6f5556304c5abb3e9ce505ec700b7ad8')
build() {
cd "${srcdir}/sexplib0-v${pkgver}"
- jbuilder build
+ dune build
}
@@ -24,7 +24,7 @@ package() {
cd "${srcdir}/sexplib0-v${pkgver}"
mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
- install -Dm755 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+ install -Dm755 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}