summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-11-28 13:04:46 +0100
committerJakob Gahde2019-11-28 13:04:46 +0100
commite2534d3ea92dc3b1b655e3c0d2f3c60d22063a0a (patch)
tree25640fdbd2fab0153b8270c1cab8f7460480f5a7
parentc840e3be97260e92d7011d379bd51833f2138a67 (diff)
downloadaur-e2534d3ea92dc3b1b655e3c0d2f3c60d22063a0a.tar.gz
ocaml-sexplib0 0.13.0-1: Update to new version
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2369830438f3..fe7a934825b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = ocaml-sexplib0
pkgdesc = Library containing the definition of S-expressions and some base converters
- pkgver = 0.12.0
- pkgrel = 2
+ pkgver = 0.13.0
+ pkgrel = 1
url = https://github.com/janestreet/sexplib0
arch = x86_64
license = MIT
makedepends = dune
+ depends = glibc
depends = ocaml
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/v0.12/files/sexplib0-v0.12.0.tar.gz
- sha512sums = 104f8526a147cfa6ecf168c8ee10a78ad3133c0a8a3714dc9dffd6358152752b337262b857c89170e07071ae669724da6f5556304c5abb3e9ce505ec700b7ad8
+ source = https://ocaml.janestreet.com/ocaml-core/v0.13/files/sexplib0-v0.13.0.tar.gz
+ sha512sums = cf9dc665919a06fdddcecdfbf5fcd1b41c20acad5d18f31302f248df4c55b6cb4cf734b73f786a9169a316d0024fe243b83868ad7d881f4ccff5a8ad746a28ca
pkgname = ocaml-sexplib0
diff --git a/PKGBUILD b/PKGBUILD
index 6af6e2e4418d..ed3ebfc244dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-sexplib0
-pkgver=0.12.0
-pkgrel=2
+pkgver=0.13.0
+pkgrel=1
pkgdesc="Library containing the definition of S-expressions and some base converters"
arch=('x86_64')
url='https://github.com/janestreet/sexplib0'
license=('MIT')
-depends=('ocaml')
+depends=('glibc' 'ocaml')
makedepends=('dune')
options=('!strip')
source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/sexplib0-v${pkgver}.tar.gz")
-sha512sums=('104f8526a147cfa6ecf168c8ee10a78ad3133c0a8a3714dc9dffd6358152752b337262b857c89170e07071ae669724da6f5556304c5abb3e9ce505ec700b7ad8')
+sha512sums=('cf9dc665919a06fdddcecdfbf5fcd1b41c20acad5d18f31302f248df4c55b6cb4cf734b73f786a9169a316d0024fe243b83868ad7d881f4ccff5a8ad746a28ca')
build() {
cd "${srcdir}/sexplib0-v${pkgver}"
@@ -23,8 +23,7 @@ build() {
package() {
cd "${srcdir}/sexplib0-v${pkgver}"
- mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
- dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
- mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ dune install --destdir "${pkgdir}"
install -Dm755 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}